Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing the upgrade of Firefox... [solved]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Sun Aug 03, 2014 3:51 pm    Post subject: Reply with quote

Code:
emerge -C virtual/python-argparse agparse vlc upower amsn openldap
emerge -1 upower-pm-utils
mkdir /usr/local/portage/metadata/layout.conf
echo "'masters = gentoo"  >> /usr/local/portage/metadata/layout.conf

Code:
emerge --nodeps perl libperl
emerge Locale-gettext
emerge --deselect --ask $(qlist -IC 'perl-core/*')
emerge -uD1a $(qlist -IC 'virtual/perl-*')
If the last command poses problems:
Code:
emerge -C sys-apps/baselayout-java dev-java/java-config app-admin/eselect-java
emerge -1 --keep-going =sys-apps/help2man-1.46.1 =sys-devel/automake-1.14.1 =sys-devel/libtool-2.4.2-r1 =media-libs/alsa-lib-1.0.28 =media-libs/fontconfig-2.11.1-r1 =x11-libs/libXi-1.7.4 =x11-libs/xtrans-1.3.4 =dev-lang/tcl-8.6.1-r1 =x11-proto/renderproto-0.11.1-r1 =x11-proto/recordproto-1.14.2-r1 =x11-libs/libXrender-0.9.8 =dev-db/sqlite-3.8.5 =x11-libs/libXtst-1.2.2 =dev-util/intltool-0.50.2-r1 =dev-libs/libxml2-2.9.1-r4 =dev-lang/python-2.7.8 =app-misc/ca-certificates-20140223.3.16-r1 =dev-libs/openssl-1.0.1h-r3 =dev-lang/python-3.3.5-r1 =dev-lang/python-3.4.1 =app-admin/eselect-1.4.2 =app-admin/eselect-java-0.1.0 =sys-libs/db-4.8.30-r1 =x11-misc/shared-mime-info-1.3 =sys-apps/coreutils-8.23 =app-admin/perl-cleaner-2.16 =dev-libs/popt-1.16-r2 =sys-apps/attr-2.4.47-r1 =sys-apps/acl-2.2.52-r1 =virtual/acl-0-r2 =sys-apps/baselayout-java-0.1.0 =dev-java/java-config-2.2.0 =dev-java/oracle-jdk-bin-1.7.0.65 =sys-apps/diffutils-3.3 =sys-devel/flex-2.5.39-r1 =dev-libs/elfutils-0.158 =dev-java/java-config-2.1.12-r1 =app-admin/eselect-java-0.1.0 =sys-apps/baselayout-java-0.1.0 =dev-java/java-config-2.1.12-r1 =dev-java/oracle-jdk-bin-1.7.0.65
in either case if successful
Code:
emerge perl-cleaner
perl-cleaner all

_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Sun Aug 03, 2014 7:53 pm    Post subject: trying to reboot... [!] Reply with quote

http://pastebin.com/rzDReTzr
trying to reboot! *laughing* That mean's the cow for me. ;) The word in german is KUH. (not to swap with su) :)

Thanks for all the help. Anyway i don't leave this topic. Well. :)

update:
Now i understand that with making little pieces.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] dev-qt/designer-4.8.5:4 USE="exceptions qt3support webkit (-aqua) -debug -declarative -pch (-phonon)" 0 kB
[ebuild U ] sys-auth/polkit-kde-agent-0.99.0-r1:4 [0.99.0:4] USE="(-aqua) -debug" LINGUAS="de -ca -ca@valencia -cs -da -en_GB -eo -es -et -fi -fr -ga -gl -hr -hu -is -it -ja -km -lt -mai -ms -nb -nds -nl -pa -pt -pt_BR -ro -ru -sk -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -uk -zh_TW" 0 kB

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 0 kB
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Mon Aug 04, 2014 12:40 am    Post subject: Reply with quote

I'm not ready yet with the system upgrade. But firefox is possible to update now.
I'll give it a try. :-)


sph4re flash # emerge -avu firefox
!!! Repository 'x-portage' is missing masters attribute in '/usr/local/portage/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

* IMPORTANT: 31 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] media-libs/libvpx-1.3.0 [1.1.0] USE="mmx sse sse2 ssse3 threads (-altivec) -avx% -avx2% -doc -postproc -sse3 -sse4_1 -static-libs {-test%} (-debug%)" 2,036 kB
[ebuild U ] dev-libs/nspr-4.10.6-r1 [4.9.4] USE="-debug" 1,105 kB
[ebuild U ] dev-libs/nss-3.16.3 [3.14.1] USE="cacert%* nss-pem%* -utils" 6,305 kB
[ebuild U ] www-client/firefox-31.0 [18.0.1] USE="dbus gstreamer jit minimal pulseaudio%* startup-notification wifi -bindist -custom-cflags -custom-optimization -debug -hardened% (-pgo) (-selinux) -system-cairo% -system-icu% -system-jpeg -system-sqlite {-test%} (-alsa%*) (-libnotify%*)" LINGUAS="de -af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -ku -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -te -th -tr -uk -vi -xh% -zh_CN -zh_TW -zu (-ak%) (-lg%) (-nso%) (-ta_LK%)" 144,440 kB

Total: 4 packages (4 upgrades), Size of downloads: 153,885 kB
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7089
Location: Saint Amant, Acadiana

PostPosted: Mon Aug 04, 2014 12:41 am    Post subject: Reply with quote

Quote:
* IMPORTANT: 31 news items need reading for repository 'gentoo'.


???
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Mon Aug 04, 2014 11:41 pm    Post subject: Reply with quote

Jaglover the news are more useful if you don't watch the update processes. - But it's just my opinion.
DONAHUE: It takes a long, long, time for updating seamonkey, so you have a days time now for yourself. :)
I will process the last posting laters after that compile.

Zitat:
* IMPORTANT: 31 news items need reading for repository 'gentoo'.

yes. yes. ... I need reading. :) :>

Jaglover: what is the command for reading it? I have it in my small book. It's a nice one then. ;)
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Mon Aug 04, 2014 11:47 pm    Post subject: Reply with quote

eselect news read
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Tue Aug 05, 2014 4:02 am    Post subject: Reply with quote

Error;
After doing # perl-cleaner all
http://pastebin.com/rQ05Pi7u
After doing # emerge -1 upower-pm-utils
http://pastebin.com/C1Gi7qnL
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Tue Aug 05, 2014 4:58 am    Post subject: Reply with quote

if we can get perl-cleaner going , upower-pm-utils will go also

Code:
mkdir /etc/portage/package.use
echo "dev-qt/qtgui dbus" >> /etc/portage/package.use
USE=" dbus" emerge =dev-qt/qtgui-4.8.5-r3
emerge -C sys-apps/baselayout-java dev-java/java-config app-admin/eselect-java openssl tiff
emerge -1 --keep-going --nodeps =sys-apps/help2man-1.46.1 =sys-devel/automake-1.14.1 =sys-devel/libtool-2.4.2-r1 =media-libs/alsa-lib-1.0.28 =media-libs/fontconfig-2.11.1-r1 =x11-libs/libXi-1.7.4 =x11-libs/xtrans-1.3.4 =dev-lang/tcl-8.6.1-r1 =x11-proto/renderproto-0.11.1-r1 =x11-proto/recordproto-1.14.2-r1 =x11-libs/libXrender-0.9.8 =dev-db/sqlite-3.8.5 =x11-libs/libXtst-1.2.2 =dev-util/intltool-0.50.2-r1 =dev-libs/libxml2-2.9.1-r4 =dev-lang/python-2.7.8 =app-misc/ca-certificates-20140223.3.16-r1 =dev-libs/openssl-1.0.1h-r3 =dev-lang/python-3.3.5-r1 =dev-lang/python-3.4.1 =app-admin/eselect-1.4.2 =app-admin/eselect-java-0.1.0 =sys-libs/db-4.8.30-r1 =x11-misc/shared-mime-info-1.3 =sys-apps/coreutils-8.23 =app-admin/perl-cleaner-2.16 =dev-libs/popt-1.16-r2 =sys-apps/attr-2.4.47-r1 =sys-apps/acl-2.2.52-r1 =virtual/acl-0-r2 =sys-apps/baselayout-java-0.1.0 =dev-java/java-config-2.2.0 =dev-java/oracle-jdk-bin-1.7.0.65 =sys-apps/diffutils-3.3 =sys-devel/flex-2.5.39-r1 =dev-libs/elfutils-0.158 =dev-java/java-config-2.1.12-r1 =app-admin/eselect-java-0.1.0 =sys-apps/baselayout-java-0.1.0 =dev-java/java-config-2.1.12-r1 =dev-java/oracle-jdk-bin-1.7.0.65 openssl tiff
if this list will not run because some package has block or slot problem, take it out of the list and try again, unmerge the package if necessary, rerun the emerge, repeating until no progress is made, then
Code:
perl-cleaner all

paste problems
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Tue Aug 05, 2014 6:33 am    Post subject: Reply with quote

# emerge -uDNv --with-bdeps=y @world

* IMPORTANT: 31 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-lang/perl:0/0=[-build(-)]".
(dependency required by "dev-perl/libintl-perl-1.230.0" [installed])
(dependency required by "sys-apps/texinfo-5.2" [installed])
(dependency required by "sys-fs/e2fsprogs-1.42.10" [ebuild])
(dependency required by "@system" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Tue Aug 05, 2014 6:55 am    Post subject: Reply with quote

Code:
emerge -s perl
emerge -pv perl
produce what?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Tue Aug 05, 2014 6:59 am    Post subject: Reply with quote

Now USE=" dbus" emerge =dev-qt/qtgui-4.8.5-r3 is running...
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Tue Aug 05, 2014 7:05 am    Post subject: Reply with quote

Quote:
emerge: there are no ebuilds to satisfy "dev-lang/perl:0/0=[-build(-)]"
never seen this before
bedtime here, look forward to your next report :D
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Wed Aug 06, 2014 1:39 pm    Post subject: Reply with quote

http://pastebin.com/AvtuKjCM
http://pastebin.com/TgpQwTRh

Should i do an emerge --sync from time to time? Maybe that world is functionating then.
I do not do this cause' i'm in the actual sync from 5days ago installing that stuff...
Code:

#  emerge -pv perl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-lang/perl-5.18.2-r1:0/5.18  USE="berkdb gdbm -debug -doc -ithreads" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

 * IMPORTANT: 31 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Wed Aug 06, 2014 5:16 pm    Post subject: Reply with quote

did packages 15 through 38 emerge?
Code:
emerge -1 XML-Parser

I would stick with the 5 day old sync until upgraded to it
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Wed Aug 06, 2014 6:55 pm    Post subject: Reply with quote

>>> Emerging (16 of 38) dev-lang/python-2.7.8::gentoo

update:
http://pastebin.com/vKFZaPWD
update2:
fixed with emerge java-config.
*** Resuming merge...
[ebuild U ] x11-misc/shared-mime-info-1.3 [1.0] USE="{-test%}"
[ebuild U ] sys-apps/coreutils-8.23 [8.22-r1] USE="-multicall%"
[ebuild U ] app-admin/perl-cleaner-2.16 [2.15]
[ebuild U ] dev-libs/popt-1.16-r2 [1.16-r1]
[ebuild U ] sys-apps/attr-2.4.47-r1 [2.4.46-r1]
[ebuild U ] sys-apps/acl-2.2.52-r1 [2.2.51]
[ebuild U ] virtual/acl-0-r2 [0-r1]
[ebuild N ] sys-apps/baselayout-java-0.1.0
[ebuild N ] dev-java/java-config-2.2.0 PYTHON_TARGETS="python2_7 python3_3 -python3_2"
[ebuild fU ] dev-java/oracle-jdk-bin-1.7.0.65 [1.7.0.11] USE="(-aqua) (-selinux)"
[ebuild U ] sys-apps/diffutils-3.3 [3.2]
[ebuild U ] sys-devel/flex-2.5.39-r1 [2.5.37]
[ebuild U ] dev-libs/elfutils-0.158 [0.155] USE="(-threads*)"
[ebuild N ] dev-java/java-config-2.1.12-r1 PYTHON_TARGETS="python2_7 python3_3 -python3_2"
[ebuild N ] media-libs/tiff-4.0.3-r6 USE="cxx jbig jpeg lzma zlib -static-libs {-test}"
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Thu Aug 07, 2014 8:23 pm    Post subject: Reply with quote

The 15 of 38 is completed.

# emerge -avuDN system

* IMPORTANT: 31 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=media-libs/libpng-1.4:0/15=".
(dependency required by "net-libs/webkit-gtk-1.10.2-r300" [installed])
(dependency required by "net-libs/libproxy-0.4.11-r2" [installed])
(dependency required by "net-libs/glib-networking-2.40.1-r1" [installed])
(dependency required by "net-libs/libsoup-2.46.0-r1" [installed])
(dependency required by "media-plugins/gst-plugins-soup-0.10.31-r1" [ebuild])
(dependency required by "media-libs/phonon-gstreamer-4.7.2[network]" [ebuild])
(dependency required by "media-libs/phonon-4.7.2[gstreamer]" [ebuild])
(dependency required by "kde-base/kdelibs-4.13.3-r1" [ebuild])
(dependency required by "kde-base/kde-l10n-4.13.3" [ebuild])
(dependency required by "sys-auth/polkit-kde-agent-0.99.0-r1[linguas_de]" [installed])
(dependency required by "sys-auth/polkit-0.112-r2[kde]" [ebuild])
(dependency required by "sys-fs/udisks-2.1.3" [ebuild])
# emerge -avuDN world

* IMPORTANT: 31 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-lang/perl:0/0=[-build(-)]".
(dependency required by "dev-perl/libintl-perl-1.230.0" [installed])
(dependency required by "sys-apps/texinfo-5.2" [installed])
(dependency required by "sys-fs/e2fsprogs-1.42.10" [ebuild])
(dependency required by "@system" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Aug 07, 2014 8:52 pm    Post subject: Reply with quote

Code:
emerge -1v `equery list -f '.*perl.*' -F '$cp'`
perl-cleaner --reallyall -- --backtrack=30
emerge -C media-libs/libpng net-libs/webkit-gtk net-libs/libproxy net-libs/glib-networking net-libs/libsoup media-plugins/gst-plugins-soup media-libs/phonon-gstreamer media-libs/phonon kde-base/kdelibs kde-base/kde-l10n sys-auth/polkit-kde-agent sys-auth/polkit sys-fs/udisks libintl-perl texinfo e2fsprogs
emerge -1 media-libs/libpng net-libs/webkit-gtk net-libs/libproxy net-libs/glib-networking net-libs/libsoup media-plugins/gst-plugins-soup media-libs/phonon-gstreamer media-libs/phonon kde-base/kdelibs  kde-base/kde-l10n sys-auth/polkit-kde-agent sys-auth/polkit sys-fs/udisks libintl-perl texinfo e2fsprogs

_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Thu Aug 07, 2014 10:20 pm    Post subject: Reply with quote

# emerge -1v `equery list -f '.*perl.*' -F '$cp'`
Traceback (most recent call last):
File "/usr/bin/equery", line 35, in <module>
from gentoolkit import equery, errors
ImportError: No module named 'gentoolkit'
emerge: the other white meat (command-line interface to the Portage system)
Usage:
emerge [ options ] [ action ] [ ebuild | tbz2 | file | @set | atom ] [ ... ]
emerge [ options ] [ action ] < @system | @world >
emerge < --sync | --metadata | --info >
emerge --resume [ --pretend | --ask | --skipfirst ]
emerge --help
Options: -[abBcCdDefgGhjkKlnNoOpPqrsStuvVw]
[ --color < y | n > ] [ --columns ]
[ --complete-graph ] [ --deep ]
[ --jobs JOBS ] [ --keep-going ] [ --load-average LOAD ]
[ --newrepo ] [ --newuse ] [ --noconfmem ] [ --nospinner ]
[ --oneshot ] [ --onlydeps ] [ --quiet-build [ y | n ] ]
[ --reinstall changed-use ] [ --with-bdeps < y | n > ]
Actions: [ --depclean | --list-sets | --search | --sync | --version ]

For more help consult the man page.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Aug 07, 2014 10:26 pm    Post subject: Reply with quote

sorry
Code:
emerge gentoolkit
start over on my last :? !'m forgetting gentoolkit is optional ..
_________________
Defund the FCC.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Thu Aug 07, 2014 10:58 pm    Post subject: Reply with quote

# perl-cleaner reallyall ...
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qtgui-4.8.0:4[accessibility,dbus]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtgui-4.8.5-r3::gentoo (Missing IUSE: dbus)
- dev-qt/qtgui-4.8.5-r2::gentoo (Missing IUSE: dbus)
(dependency required by "kde-base/kdelibs-4.9.5" [installed])
(dependency required by "sys-auth/polkit-kde-agent-0.99.0-r1" [installed])
(dependency required by "sys-auth/polkit-0.110[kde]" [installed])
(dependency required by "gnome-base/gconf-3.2.6" [installed])
(dependency required by "media-sound/pulseaudio-3.0" [installed])
(dependency required by "media-plugins/alsa-plugins-1.0.26" [installed])
* perl-cleaner is stopping here:
* Fix the problem and start perl-cleaner again.
*
* If you encounter blockers involving virtuals and perl-core, here are
* some things to try:
* Remove all perl-core packages from your world file
* emerge --deselect --ask $(qlist -IC 'perl-core/*')

* Update all the installed Perl virtuals
* emerge -uD1a $(qlist -IC 'virtual/perl-*')
* Afterwards re-run perl-cleaner
*
* Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.
sph4re flash # USE=" DBUS" emerge =dev-qt/qtgui-4.8.5-r3

oh, wait.. i see your last posting.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Thu Aug 07, 2014 11:20 pm    Post subject: Reply with quote

http://pastebin.com/9jVrYEpQ
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Aug 07, 2014 11:41 pm    Post subject: Reply with quote

Typo USE=" DBUS" --> USE="dbus"

Code:
echo "dev-qt/qtgui dbus" >> /etc/portage/package.use
Code:
mkdir /etc/portage
if needed
Code:
emerge -C CPAN-Meta perl-Test-Simple virtual/perl-Test-Simple virtual/perl-CPAN-Meta

Code:
emerge -1 --backtrack=30 CPAN-Meta perl-Test-Simple virtual/perl-Test-Simple virtual/perl-CPAN-Meta


Edit to correct virtual/CPAN-Meta to virtual/perl-CPAN-Meta
_________________
Defund the FCC.


Last edited by DONAHUE on Fri Aug 08, 2014 12:48 am; edited 3 times in total
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Thu Aug 07, 2014 11:46 pm    Post subject: Reply with quote

Look at my last pastebin.
Should we remove this Block so that it can install?
I now try perl-cleaner reallyall with that dbus useflag.
Code:

# emerge -C CPAN-Meta perl-Test-Simple virtual/perl-Test-Simple virtual/CPAN-Meta
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'perl-Test-Simple' to unmerge.

--- Couldn't find 'virtual/perl-Test-Simple' to unmerge.

--- Couldn't find 'virtual/CPAN-Meta' to unmerge.

 perl-core/CPAN-Meta
    selected: 2.132.510-r1
   protected: none
     omitted: none

All selected packages: perl-core/CPAN-Meta-2.132.510-r1

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging (1 of 1) perl-core/CPAN-Meta-2.132.510-r1...

# emerge -1 --backtrack=30 CPAN-Meta perl-Test-Simple virtual/perl-Test-Simple virtual/CPAN-Meta

 * IMPORTANT: 31 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "virtual/CPAN-Meta".

emerge: searching for similar names...
emerge: Maybe you meant any of these: virtual/perl-CPAN-Meta, virtual/pam, virtual/mta?


Last edited by ch64 on Fri Aug 08, 2014 12:28 am; edited 1 time in total
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Fri Aug 08, 2014 12:21 am    Post subject: Reply with quote

Code:

# emerge -av CPAN-Meta perl-Test-Simple

 * IMPORTANT: 31 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] virtual/perl-Test-Simple-0.980.0-r5  0 kB
[ebuild  N     ] perl-core/CPAN-Meta-2.132.510-r1  0 kB
[blocks B      ] >perl-core/Test-Simple-0.980.0-r999 (">perl-core/Test-Simple-0.980.0-r999" is blocking virtual/perl-Test-Simple-0.980.0-r5)

Total: 2 packages (2 new), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/perl-Test-Simple-0.980.0-r5:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-Test-Simple-0.980.0-r5 required by (perl-core/CPAN-Meta-2.132.510-r1:0/0::gentoo, ebuild scheduled for merge)
    perl-Test-Simple
    >=virtual/perl-Test-Simple-0.88 required by (perl-core/CPAN-Meta-2.132.510-r1:0/0::gentoo, ebuild scheduled for merge)

  (perl-core/Test-Simple-0.980.5-r1:0/0::gentoo, installed) pulled in by
    perl-core/Test-Simple required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 316

PostPosted: Fri Aug 08, 2014 12:27 am    Post subject: Reply with quote

With dbus in package.use
Code:

# perl-cleaner reallyall
These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-qt/qtgui-4.8.0:4[accessibility,dbus]".
!!! One of the following packages is required to complete your request:
- dev-qt/qtgui-4.8.5-r3::gentoo (Missing IUSE: dbus)
- dev-qt/qtgui-4.8.5-r2::gentoo (Missing IUSE: dbus)
(dependency required by "kde-base/kde-l10n-4.9.5" [installed])
(dependency required by "sys-auth/polkit-kde-agent-0.99.0-r1[linguas_de]" [installed])
(dependency required by "sys-auth/polkit-0.110[kde]" [installed])
(dependency required by "sys-auth/consolekit-0.4.5_p20120320-r1" [installed])
 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum