Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
bbswitch-Probleme mit Thinkpad T440p
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Spixi
n00b
n00b


Joined: 16 Nov 2012
Posts: 40

PostPosted: Sat Jul 19, 2014 12:40 pm    Post subject: bbswitch-Probleme mit Thinkpad T440p Reply with quote

Hallo liebe Community,

ich habe mir ein neues Thinkpad T440p gekauft und Gentoo installiert, nun bekomme ich Probleme mit Bumblebee (GeForce GT 730M). Ich benutze lightdm und Mate. Das BIOS-Downgrade auf Version 1.14 habe ich bereits durchgeführt.

tail -f /var/log/Xorg.0.log zeigt, dass sich udev und xf86 aus irgendeinem Grund ständig in die Quere kommen.

Code:
[   991.451] (II) config/udev: Adding drm device (/dev/dri/card1)
[   991.454] removing GPU device /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1 /dev/dri/card1
[   991.454] xf86: remove device 0 /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1
[   991.484] removing GPU device /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1 /dev/dri/card1
[   991.484] xf86: remove device 0 /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1
[   991.484] (II) config/udev: Adding drm device (/dev/dri/card1)
[   991.487] removing GPU device /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1 /dev/dri/card1
[   991.487] xf86: remove device 0 /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1
[   991.516] removing GPU device /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1 /dev/dri/card1
[   991.516] xf86: remove device 0 /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1
[   991.516] (II) config/udev: Adding drm device (/dev/dri/card1)
[   991.519] removing GPU device /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1 /dev/dri/card1
[   991.519] xf86: remove device 0 /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1
[   991.549] removing GPU device /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1 /dev/dri/card1
[   991.549] xf86: remove device 0 /sys/devices/pci0000:00/0000:00:01.1/0000:02:00.0/drm/card1



Die CPU läuft einige Minuten nach Systemstart auf Hochtouren. Das Programm /lib/systemd/systemd-udevd hat eine CPU-Auslastung von 799% (obwohl ich OpenRC und nicht systemd benutze!) und das System wird stark erhitzt. Ruhe ist erst, wenn ich bumblebee neu starte (rc -s bumblebee restart).


Woran liegt das? Habe ich etwas bei der Konfiguration übersehen oder muss ich als Workaround ein weiteres Init-Script erstellen? So musste ich in der Form bereits für wpa_supplicant erstellen:

Code:
#!/sbin/runscript
depend() {
  before net.wlp4s0
}

start() {
  xargs kill -9 < /var/run/wpa_supplicant-wlp4s0.pid
  [ -e /var/run/wpa_supplicant/* ] && rm /var/run/wpa_supplicant/wlp4s0
  true
}



Systeminformationen:
emerge --info wrote:
spixxi mari # emerge --info
Portage 2.2.8-r1 (default/linux/amd64/13.0/no-multilib, gcc-4.7.3, glibc-2.17, 3.12.21-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.12.21-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-4800MQ_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem: 7900040 total, 5984828 free
KiB Swap: 16776188 total, 16776188 free
Timestamp of tree: Thu, 17 Jul 2014 21:15:01 +0000
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash: 4.2_p45
dev-lang/python: 2.7.6, 3.3.3
dev-util/cmake: 2.8.12.2
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.12.4
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.11.6, 1.13.4
sys-devel/binutils: 2.23.2
sys-devel/gcc: 4.7.3-r1
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4.2
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc: 2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core-avx2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core-avx2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.halifax.rwth-aachen.de/gentoo/ http://mirror.netcologne.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 apng berkdb bluetooth bzip2 cairo caja cdda cg cli consolekit cracklib crypt cups cxx dbus dri dvd fax ffpmeg fortran fuse gdbm gdu glew glut gnome-keyring gtk gudev hpijs iconv imagemagick ipv6 jpeg jpg lame mmx modules mp3 mpeg ncurses nls nptl nvidea ogg opencl openexr opengl openmp pam pango pcre png policykit python readline samba scanner session sound sqlite sse sse2 ssl tcpd theora tiff truetype unicode uvm v4l vdpau vorbis wifi xcb xinerama xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


eix -I '(x(f86.+)|(org-server))|(b(bswitch)|(umblebee))|(nvidia.*)' wrote:

[I] dev-util/nvidia-cuda-toolkit
Available versions: 4.2.9-r2 5.5.22(0/5.5.22) ~6.0.37-r3(0/6.0.37) {debugger doc eclipse profiler}
Installed versions: 5.5.22(02:54:56 06.07.2014)(-debugger -doc -eclipse -profiler)
Homepage: http://developer.nvidia.com/cuda
Description: NVIDIA CUDA Toolkit (compiler and friends)

[I] media-gfx/nvidia-cg-toolkit
Available versions: 3.1.0013-r2^s ~3.1.0013-r3^s {doc examples multilib ABI_X86="32 64"}
Installed versions: 3.1.0013-r2^s(19:27:06 05.07.2014)(-doc -examples -multilib)
Homepage: http://developer.nvidia.com/object/cg_toolkit.html
Description: NVIDIA's C graphics compiler toolkit

[I] media-gfx/nvidia-texture-tools
Available versions: 2.0.8-r1 2.0.8-r2 {cg cuda glew glut openexr}
Installed versions: 2.0.8-r2(05:12:02 06.07.2014)(cg glew glut openexr -cuda)
Homepage: http://developer.nvidia.com/object/texture_tools.html
Description: A set of cuda-enabled texture tools and compressors

[I] sys-power/bbswitch
Available versions: 0.7 0.8 {KERNEL="linux"}
Installed versions: 0.8(08:18:27 18.07.2014)(KERNEL="linux")
Homepage: https://github.com/Bumblebee-Project/bbswitch
Description: Toggle discrete NVIDIA Optimus graphics card

[I] x11-base/xorg-server
Available versions: 1.9.5-r3(0/1.9.5) 1.10.6-r3(0/1.10.6) 1.11.4-r3(0/1.11.4) 1.12.4-r2(0/1.12.4) 1.13.4-r1(0/1.13.4) 1.14.5(0/1.14.5) ~1.14.7(0/1.14.7) 1.15.0(0/1.15.0) ~1.15.1(0/1.15.1) ~1.15.99.903(0/1.15.99.903) {dmx doc glamor ipv6 kdrive minimal nptl selinux static-libs +suid systemd tslib +udev unwind wayland xnest xorg xvfb}
Installed versions: 1.15.0(07:08:30 06.07.2014)(ipv6 nptl suid udev xorg -dmx -doc -kdrive -minimal -selinux -static-libs -tslib -unwind -xnest -xvfb)
Homepage: http://xorg.freedesktop.org/
Description: X.Org X servers

[I] x11-drivers/nvidia-drivers
Available versions: 96.43.23^msd 173.14.39^msd 304.121^msd 331.79^msd 334.21-r3^msd 337.25^msd ~340.17^msd {+X acpi custom-cflags gtk multilib pax_kernel (+)tools uvm KERNEL="FreeBSD linux"}
Installed versions: 337.25^msd(08:19:00 18.07.2014)(X acpi tools uvm -multilib -pax_kernel KERNEL="linux -FreeBSD")
Homepage: http://www.nvidia.com/
Description: NVIDIA Accelerated Graphics Driver

[I] x11-drivers/xf86-input-evdev
Available versions: 2.7.3 2.8.1 2.8.2 ~2.8.4 [M]~2.9.0
Installed versions: 2.8.2(06:55:59 06.07.2014)
Homepage: http://xorg.freedesktop.org/
Description: Generic Linux input driver

[I] x11-drivers/xf86-input-synaptics
Available versions: 1.4.0 ~1.5.2 ~1.6.4 1.7.1 1.7.4 ~1.7.6 [M]~1.8.0 {KERNEL="linux"}
Installed versions: 1.7.4(06:56:11 06.07.2014)
Homepage: http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/
Description: Driver for Synaptics touchpads

[I] x11-drivers/xf86-video-intel
Available versions: ~*2.9.1 2.19.0 2.20.13 2.21.15 ~2.99.903 ~2.99.905-r1 ~2.99.906 ~2.99.907-r1 ~2.99.909 ~2.99.910 ~2.99.911-r1 ~2.99.912 ~2.99.912-r1 {debug dri glamor (+)sna +udev uxa xvmc}
Installed versions: 2.21.15(09:17:42 18.07.2014)(dri sna udev xvmc -glamor -uxa)
Homepage: http://xorg.freedesktop.org/
Description: X.Org driver for Intel cards

[I] x11-libs/libXxf86misc
Available versions: 1.0.3 {static-libs}
Installed versions: 1.0.3(19:13:40 29.06.2014)(-static-libs)
Homepage: http://xorg.freedesktop.org/
Description: X.Org Xxf86misc library

[I] x11-libs/libXxf86vm
Available versions: 1.1.3 {static-libs ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
Installed versions: 1.1.3(05:18:32 29.06.2014)(-static-libs ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32")
Homepage: http://xorg.freedesktop.org/
Description: X.Org Xxf86vm library

[I] x11-misc/bumblebee
Available versions: 3.2.1 {+bbswitch VIDEO_CARDS="nouveau nvidia"}
Installed versions: 3.2.1(06:36:27 06.07.2014)(bbswitch VIDEO_CARDS="nvidia -nouveau")
Homepage: http://bumblebee-project.org https://github.com/Bumblebee-Project/Bumblebee
Description: Service providing elegant and stable means of managing Optimus graphics chipsets

[I] x11-proto/xf86bigfontproto
Available versions: 1.2.0 1.2.0-r1 {ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
Installed versions: 1.2.0-r1(05:08:52 29.06.2014)(ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32")
Homepage: http://xorg.freedesktop.org/
Description: X.Org XF86BigFont protocol headers

[I] x11-proto/xf86dgaproto
Available versions: 2.1 2.1-r1 2.1-r2 {ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
Installed versions: 2.1-r2(05:07:15 29.06.2014)(ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32")
Homepage: http://xorg.freedesktop.org/
Description: X.Org XF86DGA protocol headers

[I] x11-proto/xf86driproto
Available versions: 2.1.1 2.1.1-r1 {ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
Installed versions: 2.1.1-r1(05:05:28 29.06.2014)(ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32")
Homepage: http://xorg.freedesktop.org/
Description: X.Org XF86DRI protocol headers

[I] x11-proto/xf86miscproto
Available versions: 0.9.3
Installed versions: 0.9.3(19:12:58 29.06.2014)
Homepage: http://xorg.freedesktop.org/
Description: X.Org XF86Misc protocol headers

[I] x11-proto/xf86rushproto
Available versions: 1.1.2 1.1.2-r1
Installed versions: 1.1.2-r1(05:07:28 29.06.2014)
Homepage: http://xorg.freedesktop.org/
Description: X.Org XF86Rush protocol headers

[I] x11-proto/xf86vidmodeproto
Available versions: 2.3.1 2.3.1-r1 {ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
Installed versions: 2.3.1-r1(05:06:00 29.06.2014)(ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32")
Homepage: http://xorg.freedesktop.org/
Description: X.Org XF86VidMode protocol headers


cat /etc/portage/make.conf wrote:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=core-avx2 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j9"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="mmx sse sse2 -pulseaudio alsa vdpau sound wifi cairo -qt4 -kde gtk bluetooth dbus fuse samba X nvidea -nuoveau xvmc png xcb imagemagick truetype pango python apng sqlite opencl opengl jpg cups tiff mp3 lame ffpmeg mpeg cdda dvd v4l ogg theora vorbis xinerama consolekit gudev consolekit policykit gdu pam gnome-keyring jpeg acpi uvm openexr cg glew glut unicode caja scanner fax hpijs"
PYTHON_TARGETS="python2_7 python3_3"
VIDEO_CARDS="intel nvidia"
INPUT_DEVICES="evdev synaptics"
LINGUAS="en de"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

GENTOO_MIRRORS="ftp://ftp.halifax.rwth-aachen.de/gentoo/ http://mirror.netcologne.de/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"



x11-drivers/xf86-video-modesetting und nouveau habe ich nicht installiert.
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Sun Jul 20, 2014 11:55 am    Post subject: Reply with quote

Zu dem wpa_supplicant Problem.
Du bekommst bestimmt eine solche Meldung
Quote:
net.wlp3s0 | * Bringing up interface wlp3s0
dhcpcd | * Starting DHCP Client Daemon ...
net.wlp3s0 | * Starting wpa_supplicant on wlp3s0 ...
net.wlp3s0 |Successfully initialized wpa_supplicant
net.wlp3s0 |ctrl_iface exists and seems to be in use - cannot override it
net.wlp3s0 |Delete '/var/run/wpa_supplicant/wlp3s0' manually if it is not used anymore
net.wlp3s0 |Failed to initialize control interface '/var/run/wpa_supplicant'.
net.wlp3s0 |You may have another wpa_supplicant process already running or the file was
net.wlp3s0 |left by an unclean termination of wpa_supplicant in which case you will need
net.wlp3s0 |to manually remove this file before starting wpa_supplicant again.
net.wlp3s0 |
[ ok ]
net.wlp3s0 | * start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'
[ !! ]
net.wlp3s0 | * ERROR: net.wlp3s0 failed to start
Das liegt daran, dass wpa_supplicant zweil Mal gestartet wird.
Kannst du die /etc/conf.d/net posten ?

Du gibst etwas wenig Info's. So wird kaum jemand etwas sagen.
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
Spixi
n00b
n00b


Joined: 16 Nov 2012
Posts: 40

PostPosted: Sun Jul 20, 2014 12:08 pm    Post subject: Reply with quote

Jean-Paul wrote:
Zu dem wpa_supplicant Problem.
Du bekommst bestimmt eine solche Meldung
Quote:
net.wlp3s0 | * Bringing up interface wlp3s0
dhcpcd | * Starting DHCP Client Daemon ...
net.wlp3s0 | * Starting wpa_supplicant on wlp3s0 ...
net.wlp3s0 |Successfully initialized wpa_supplicant
net.wlp3s0 |ctrl_iface exists and seems to be in use - cannot override it
net.wlp3s0 |Delete '/var/run/wpa_supplicant/wlp3s0' manually if it is not used anymore
net.wlp3s0 |Failed to initialize control interface '/var/run/wpa_supplicant'.
net.wlp3s0 |You may have another wpa_supplicant process already running or the file was
net.wlp3s0 |left by an unclean termination of wpa_supplicant in which case you will need
net.wlp3s0 |to manually remove this file before starting wpa_supplicant again.
net.wlp3s0 |
[ ok ]
net.wlp3s0 | * start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'
[ !! ]
net.wlp3s0 | * ERROR: net.wlp3s0 failed to start
Das liegt daran, dass wpa_supplicant zweil Mal gestartet wird.
Kannst du die /etc/conf.d/net posten ?

Du gibst etwas wenig Info's. So wird kaum jemand etwas sagen.


Das WPA_supplicant-Problem ist nicht so dramatisch, hier meine /etc/conf.d/net:
Code:
modules="wpa_supplicant"
wpa_supplicant_wlp4s0="-Dnl80211 -Dwext"
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Sun Jul 20, 2014 12:25 pm    Post subject: Reply with quote

Hmm, das Einzige das mir hier jetzt auffällt ist:
Quote:
modules="wpa_supplicant"
anstatt
Quote:
modules_wlp4s0="wpa_supplicant"
Wenn du den wpa_supplicant sonst nicht separat startest, sollte es eigentlich funktionieren.
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Jul 20, 2014 12:49 pm    Post subject: Reply with quote

Spixi wrote:
Das WPA_supplicant-Problem ist nicht so dramatisch, hier meine /etc/conf.d/net:
Code:
modules="wpa_supplicant"
wpa_supplicant_wlp4s0="-Dnl80211 -Dwext"

Hm, ist -Dnl80211 und -Dwext setzen wirklich nötig?
Ich denk mal entweder oder, aber nicht beides zusammen.
Back to top
View user's profile Send private message
Spixi
n00b
n00b


Joined: 16 Nov 2012
Posts: 40

PostPosted: Sun Jul 20, 2014 1:15 pm    Post subject: Reply with quote

Josef.95 wrote:

Hm, ist -Dnl80211 und -Dwext setzen wirklich nötig?
Ich denk mal entweder oder, aber nicht beides zusammen.


Ich habe es nur mit wext und nur mit nl80211 probiert und es funktioniert nur, wenn ich beide angebe. Die Fehlermeldung "ctrl_iface exists and seems to be in use - cannot override it" tritt trotzdem auf, weil immer noch zwei Instanzen von wpa_supplicant gestartet werden. Aber das ist wie gesagt nicht mein Problem. Das Problem das ich habe ist, dass bbswitch/Bumblebee mein System lahmlegen.
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 482

PostPosted: Mon Jul 21, 2014 10:01 am    Post subject: Reply with quote

Zu dem Bumblebee-Problem: Ich hatte ein ähnliches (vlt. sogar gleiches) Problem: https://bugs.gentoo.org/show_bug.cgi?id=508196 . Die (vorübergehende) Lösung:
Code:
mv /opt/bin/nvidia-modprobe /opt/bin/nvidia-modprobe.bak
Dieses "nvidia-modprobe" verursacht das Problem. Wenn es nicht da ist, läuft alles stabil. Umbenennen damit man es rückgängig machen kann. Probiere ob es bei Deinem Problem hilft.
Back to top
View user's profile Send private message
Spixi
n00b
n00b


Joined: 16 Nov 2012
Posts: 40

PostPosted: Tue Jul 22, 2014 5:18 pm    Post subject: Reply with quote

Vielen Dank, das hier hat mir geholfen:

Code:
mv /opt/bin/nvidia-modprobe /opt/bin/nvidia-modprobe~
ln -s /bin/true /opt/bin/nvidia-modprobe
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum