Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel > 3.12 - stuck at processing uevents, enumerate USB
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Zarhan
l33t
l33t


Joined: 27 Feb 2004
Posts: 960

PostPosted: Sun Jul 20, 2014 4:38 pm    Post subject: Kernel > 3.12 - stuck at processing uevents, enumerate US Reply with quote

When I tried upgrading kernel from 3.12.24 to 3.14 or 3.15, things fail.

First, when I boot, the system freezes at "processing uevents" for almost a minute.

Stuff like this appears in dmesg (and /var/log/messages) for multiple devices.

Code:
usb 4-1.4: device not accepting address 6, error -110
hub 4-1:1.0: unable to enumerate USB device on port 4


Then, if I just log in to e.g. KDE I notice that suspend/hibernate functions are gone. However, if I wait for the enumeration to fail on all the USB devices (there are plenty, it's a Lenovo W510 laptop), things work relatively normally.

The weird part is that USB devices seem to work ok, apart from built-in Qualcomm Gobi 3G/GPS.

Anyway, if I unload/reload ehci-pci module, same messages appear in dmesg. If I do 'lsusb', it also freezes until all devices have been deal with.

This does not happen with kernel 3.12.24. I've compile 3.14 (or 15) pretty much with same options as always (copy over the old config, type make oldconfig and off I go...).

Any ideas on what's going on and how to fix it, do I need some kernel option in newer kernels? Computer is Lenovo W510 laptop.
Back to top
View user's profile Send private message
Zarhan
l33t
l33t


Joined: 27 Feb 2004
Posts: 960

PostPosted: Sun Jul 20, 2014 6:01 pm    Post subject: Reply with quote

Actually, looks like this is caused by upgrade from udev-208 to 212. If I downgrade udev, it works regardless of kernel version.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1696

PostPosted: Sun Jul 20, 2014 6:34 pm    Post subject: Reply with quote

I doubt I will be much help, in troubleshooting this; as I don't kow much about troubleshooting kernels and stuff. Though, on my my system I'm using kernel 3.15.1 with udev-15 without any issues with ehci-pci module. I'll see if I can see about downgrading my udev version to 212, see if I encounter any issues myself (probably end up breaking my machine, but that's part of the fun for me :D ). Just wondering, do you have any of the issues without the ehci-pci module loaded.

*UPDATE*

Ok, I downgraded my udev to 212 and rebooted my machine and didn't have any issues show up on my dmesg irt ehci-pci or usb in general (have a possible issue with my network driver firmware, and maybe something to my ACPI, but that's not important right now). Here's a link to my kernel's config; maybe it'll help you figure out what's going on.

http://pastebin.com/PXQLrT1w
Back to top
View user's profile Send private message
Zarhan
l33t
l33t


Joined: 27 Feb 2004
Posts: 960

PostPosted: Tue Jul 22, 2014 4:53 pm    Post subject: Reply with quote

Apparently my problems are caused by a broken Qualcomm 2000 3G modem (behind qcserial). Or kernel module using that. Doesn't matter that much since I don't use it. I was able to resolve the issue by removing qcserial from my kernel altogether.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum