Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]why do all the packages require a floppy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
JACEM
n00b
n00b


Joined: 07 Apr 2005
Posts: 42

PostPosted: Mon Jul 21, 2014 11:24 pm    Post subject: [SOLVED]why do all the packages require a floppy Reply with quote

Why are all my compiles failing because the system can't find /dev/fd.

I have a laptop without a floppy and nothing will compile.

Code:

>>>  '/var/tmp/portage/dev-libs/expat-2.1.0-r3/temp/build.log'

 * Messages for package dev-libs/expat-2.1.0-r3:

 * You're missing a /dev/fd symlink to /proc/self/fd.
 * Please fix the symlink and check your boot scripts (udev/etc...).
 * ERROR: dev-libs/expat-2.1.0-r3::gentoo failed (configure phase):
 *   /dev/fd is broken
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 2892:  Called multilib-minimal_src_configure
 *   environment, line 2153:  Called multilib_parallel_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2443:  Called multibuild_parallel_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2045:  Called multijob_init '-j3'
 *   environment, line 2108:  Called redirect_alloc_fd 'mj_write_fd' '/var/tmp/portage/dev-libs/expat-2.1.0-r3/temp/multijob.pipe'
 *   environment, line 2858:  Called die
 * The specific snippet of code:
 *           die "/dev/fd is broken";
 *
 * If you need support, post the output of `emerge --info '=dev-libs/expat-2.1.0-r3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/expat-2.1.0-r3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-libs/expat-2.1.0-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/expat-2.1.0-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-libs/expat-2.1.0-r3/work/expat-2.1.0'
 * S: '/var/tmp/portage/dev-libs/expat-2.1.0-r3/work/expat-2.1.0'


jacem


Last edited by JACEM on Tue Jul 22, 2014 12:07 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Mon Jul 21, 2014 11:54 pm    Post subject: Reply with quote

fd is actually "file descriptor" directory not "floppy drive" and points to a directory that contains pointers to the files that a particular process has open. You should have a symlink from /dev/fd to /proc/self/fd placed manually if you don't use udev. If you are using udev, something is kind of broken in your udev/mdev/other automatic /dev population setup... Try etc-update to make sure you don't have stale configuration files, but in the mean time you can link it manually:

cd /dev
ln -s self/fd fd
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
JACEM
n00b
n00b


Joined: 07 Apr 2005
Posts: 42

PostPosted: Tue Jul 22, 2014 12:01 am    Post subject: Thank you thank you thank you Reply with quote

THANK YOU

yes I meant to yell it. I've been getting that wrong all day and every one I've asked about got it just as wrong

thank you

jacem
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum