Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sdcard suddenly disappeared
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Tue Jul 22, 2014 3:10 am    Post subject: sdcard suddenly disappeared Reply with quote

Was working a short time ago; don't know what changed
but no longer recognizes cards or populates /dev

thinkpad T440S

lspci:

Quote:
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)


when rtsx_pci module is inserted:

Quote:
Jul 21 22:47:42 olwe kernel: rtsx_pci 0000:02:00.0: irq 63 for MSI/MSI-X
Jul 21 22:47:42 olwe kernel: rtsx_pci 0000:02:00.0: rtsx_pci_acquire_irq: pcr->msi_en = 1, pci->irq = 63
Jul 21 22:47:42 olwe kernel: rtsx_pci: probe of 0000:02:00.0 failed with error -110


kernel is 3.15.6 but earlier kernels show the same failure (that is, kernels where I know
the reader worked)

any help would be appreciated

EDIT: booted into windows; sdcard reader works fine
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jul 22, 2014 2:56 pm    Post subject: Reply with quote

Could be IOMMU related issue, try booting with intel_iommu=off kernel parameter.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Tue Jul 22, 2014 4:14 pm    Post subject: Reply with quote

thanks for the tip, I tried the iommu thing but it made no difference

but the big news is that due to the hacking around of somebody over at

http://askubuntu.com/questions/492476/internal-sd-card-reader-not-mounted-detected-hp-realtek-rts5227

there is a modified driver taken from realtek's webpage (rts5227.ko)

this driver works after banging it into the /lib/modules...

** but after using this driver another reboot left me with no sd card reader found
in lspci !!! **

** then after a cold reboot, the original driver works again **

this sort of voodoo might suggest failing hardware :(
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Tue Jul 22, 2014 4:18 pm    Post subject: Reply with quote

It could also be that the computer's firmware entered some non-accepting state which was only fixed by a cold boot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum