Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
webkit-gtk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
JACEM
n00b
n00b


Joined: 07 Apr 2005
Posts: 42

PostPosted: Tue Jul 22, 2014 10:41 pm    Post subject: webkit-gtk Reply with quote

webkit-gtk will not install without clang 3 or better or gcc 4.7 or better

I assume it means sys-devel/clang which is at 3.3-100 gcc-4.7 crashes my system every time I try to compile it does

help please

jacem
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13842

PostPosted: Tue Jul 22, 2014 11:08 pm    Post subject: Reply with quote

What kind of help would you like? You have a separate thread open for the reported gcc-4.7 crash. You could try using gcc-4.8 or gcc-4.9 if you cannot build gcc-4.7.
Back to top
View user's profile Send private message
JACEM
n00b
n00b


Joined: 07 Apr 2005
Posts: 42

PostPosted: Tue Jul 22, 2014 11:47 pm    Post subject: Reply with quote

I'm trying to emerge webkit-gtk.

It refuses to install because its says I need clang > 3.0 I have clang 3.3 installed I can't get gcc 4.7 to install because compiling it crashes my system.

so how do emerge webkit-gtk?

jacem
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13842

PostPosted: Tue Jul 22, 2014 11:54 pm    Post subject: Reply with quote

Despite your very old join date, you still are bad about not posting useful information. I assume you are referring to the error message "You need at least GCC 4.7.x or Clang >= 3.3 for C++11-specific compiler flags" (not clang 3.0 as you said). If so, then according to the surrounding logic in the ebuild, you need to set your system compiler to one which understands the option -std=c++11. If you do not want to set the active compiler to clang, then you could try my prior suggestion of using a newer version of gcc.
Back to top
View user's profile Send private message
JACEM
n00b
n00b


Joined: 07 Apr 2005
Posts: 42

PostPosted: Wed Jul 23, 2014 12:28 am    Post subject: Reply with quote

gcc version 4.8 and 4.9 are not considered stable in my build tree.

equery is giving me the error

Code:

Traceback (most recent call last):
file "/usr/bin/equery", line 35, in <module>
from gentoolkit import equery, error
ImortError: No Module named 'gentookit'


according to emerge --search gcc

latest version available 4.7.3-r1
latest version installed 4.6.3

The web site says that 4.8 and 4.9 are unstable in any hardware environment, of the 4.7 s 4.7.3-rz is the only one available. it's an amd64 environment.

jacem

ten eleven years ago there was an article in the linux journal I think that talked about this neat little distro called gentoo that was a shortcut to a linux from scratch system. it's gotten slowly more ridged for years.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum