Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[resolved] linux booting = disabled keyboard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
nox3r
n00b
n00b


Joined: 29 Sep 2013
Posts: 12

PostPosted: Wed Jul 23, 2014 6:17 pm    Post subject: [resolved] linux booting = disabled keyboard Reply with quote

Hello,

My keyboard is disabled during booting gentoo from CD minimal or usb bootable disc.

I tried also sysrescuecd on usb with same effect. I am not sure maybe I got disabled some option in BIOS, or I have fake keyboard :roll:

my mainboard: gigabyte 970a-ud3p

any ideas ? :?:


Last edited by nox3r on Sat Sep 06, 2014 12:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Wed Jul 23, 2014 6:44 pm    Post subject: Reply with quote

manufacturer, make, model, connection type of keyboard?
do the keyboard leds light up in the first moments of booting? can you use del, F1, F2, or F8 keys to enter bios?
cheap (I have several working for years now) ps/2 wired keyboards sell for 6 dollars and up around here.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
jows
n00b
n00b


Joined: 12 Jan 2013
Posts: 11

PostPosted: Wed Jul 23, 2014 7:52 pm    Post subject: Reply with quote

Have you tried several USB ports?
I had the same problems with a speedlink keyboard, which needs an extra kernel module *sigh*
The module was called hid_sunplus
I don´t know if it is already included on your livecds.
Back to top
View user's profile Send private message
nox3r
n00b
n00b


Joined: 29 Sep 2013
Posts: 12

PostPosted: Wed Sep 03, 2014 11:05 am    Post subject: Reply with quote

keyboard working fine in bios menu, it fails - together with mouse after I started linux booting process.

IOMMU option in BIOS doesnt resolved problem.
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1733
Location: St. Wendel

PostPosted: Wed Sep 03, 2014 11:42 am    Post subject: Reply with quote

Try

Code:
acpi=off noapic iommu=soft


as Kernel cmdline.
Back to top
View user's profile Send private message
nymexthegreat
n00b
n00b


Joined: 31 Aug 2014
Posts: 11

PostPosted: Wed Sep 03, 2014 9:14 pm    Post subject: Reply with quote

I have the 990fxa-udp3 rev 4

To get usb and networking I had to:

Enable the iommu in bios

Add iommu=soft to the boot line in grub

Edit: setting xhci and ahci handoff (or legacy or something) in the bios may also help.
Back to top
View user's profile Send private message
nox3r
n00b
n00b


Joined: 29 Sep 2013
Posts: 12

PostPosted: Sat Sep 06, 2014 12:04 pm    Post subject: Reply with quote

yes I confirm, kernel option iommu=soft fix my issue. thx :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum