Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pulseaudio issues: snd_pcm_avail() returned a value...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Tue Jul 29, 2014 8:03 pm    Post subject: Pulseaudio issues: snd_pcm_avail() returned a value... Reply with quote

Hi there:
I'm doing a new install of gentoo on a PC desktop that has a USB devices:
Code:
# lsusb
Bus 001 Device 003: ID 18ec:3399 Arkmicro Technologies Inc.
Bus 001 Device 002: ID 090c:6300 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

The problem is that this error with pulseaudio (all in red colour) and sometimes I have to reconnect the webcam:
Code:
journalctl -b | grep pulseaudio
jul 29 16:52:16 localhost pulseaudio[3114]: Default and alternate sample rates are the same.
jul 29 16:52:17 localhost pulseaudio[3132]: Daemon already running.
jul 29 16:52:17 localhost pulseaudio[3135]: [pulseaudio] pid.c: Daemon already running.
jul 29 16:52:17 localhost pulseaudio[3137]: [pulseaudio] pid.c: Daemon already running.
jul 29 16:52:17 localhost pulseaudio[3114]: snd_pcm_avail() returned a value that is exceptionally large: 49248 bytes (513 ms).
jul 29 16:52:17 localhost pulseaudio[3114]: Most likely this is a bug in the ALSA driver 'snd_usb_audio'. Please report this issue to the ALSA developers.
jul 29 16:52:17 localhost pulseaudio[3114]: snd_pcm_dump():
jul 29 16:52:17 localhost pulseaudio[3114]: Hardware PCM card 2 'USB2.0 PC CAMERA' device 0 subdevice 0
jul 29 16:52:17 localhost pulseaudio[3114]: Its setup is:
jul 29 16:52:17 localhost pulseaudio[3114]:   stream       : CAPTURE
jul 29 16:52:17 localhost pulseaudio[3114]:   access       : MMAP_INTERLEAVED
jul 29 16:52:17 localhost pulseaudio[3114]:   format       : S16_LE
jul 29 16:52:17 localhost pulseaudio[3114]:   subformat    : STD
jul 29 16:52:17 localhost pulseaudio[3114]:   channels     : 1
jul 29 16:52:17 localhost pulseaudio[3114]:   rate         : 48000
jul 29 16:52:17 localhost pulseaudio[3114]:   exact rate   : 48000 (48000/1)
jul 29 16:52:17 localhost pulseaudio[3114]:   msbits       : 16
jul 29 16:52:17 localhost pulseaudio[3114]:   buffer_size  : 4797
jul 29 16:52:17 localhost pulseaudio[3114]:   period_size  : 1199
jul 29 16:52:17 localhost pulseaudio[3114]:   period_time  : 24979
jul 29 16:52:17 localhost pulseaudio[3114]:   tstamp_mode  : ENABLE
jul 29 16:52:17 localhost pulseaudio[3114]:   period_step  : 1
jul 29 16:52:17 localhost pulseaudio[3114]:   avail_min    : 1199
jul 29 16:52:17 localhost pulseaudio[3114]:   period_event : 1
jul 29 16:52:17 localhost pulseaudio[3114]:   start_threshold  : -1
jul 29 16:52:17 localhost pulseaudio[3114]:   stop_threshold   : 5400941853124067328
jul 29 16:52:17 localhost pulseaudio[3114]:   silence_threshold: 0
jul 29 16:52:17 localhost pulseaudio[3114]:   silence_size : 0
jul 29 16:52:17 localhost pulseaudio[3114]:   boundary     : 5400941853124067328
jul 29 16:52:17 localhost pulseaudio[3114]:   appl_ptr     : 1200
jul 29 16:52:17 localhost pulseaudio[3114]:   hw_ptr       : 25824
jul 29 16:52:17 localhost pulseaudio[3114]: ALSA woke us up to read new data from the device, but there was actually nothing to read!
jul 29 16:52:17 localhost pulseaudio[3114]: Most likely this is a bug in the ALSA driver 'snd_usb_audio'. Please report this issue to the ALSA developers.
jul 29 16:52:17 localhost pulseaudio[3114]: We were woken up with POLLIN set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.

How can I fix this error?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum