Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Build BitcoinArmory - undefined symbol
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Wed Aug 06, 2014 11:40 am    Post subject: [Solved] Build BitcoinArmory - undefined symbol Reply with quote

Using BitcoinArmory source from https://github.com/etotheipi/BitcoinArmory/releases/tag/v0.92.1

I extract the archive then cd into the directory and do a 'make'

To run it, I use
Code:
/usr/bin/python2 ArmoryQt.py

Problem is, I see
Code:
$ /usr/bin/python2 ArmoryQt.py
Traceback (most recent call last):
  File "ArmoryQt.py", line 34, in <module>
    import CppBlockUtils as Cpp
  File "/home/lyall/Source/BitcoinArmory-0.92.1/CppBlockUtils.py", line 28, in <module>
    _CppBlockUtils = swig_import_helper()
  File "/home/lyall/Source/BitcoinArmory-0.92.1/CppBlockUtils.py", line 24, in swig_import_helper
    _mod = imp.load_module('_CppBlockUtils', fp, pathname, description)
ImportError: /home/lyall/Source/BitcoinArmory-0.92.1/_CppBlockUtils.so: undefined symbol: _ZN6snappy21GetUncompressedLengthEPKcmPm


Based on the windows build instructions, the following packages are installed.

Code:
lyall@lyalls-pc ~/Source/BitcoinArmory-0.92.1
$ eix --installed twisted
[I] dev-python/twisted-core
     Available versions:  12.3.0 ~12.3.0-r1 ~13.0.0 13.0.0-r3 ~13.2.0 [m]13.2.0-r1000[1] ~14.0.0 {crypt gtk pygobject serial test wxwidgets PYTHON_ABIS="2.6 2.7 2.7-pypy-2.0" PYTHON_TARGETS="python2_7"}
     Installed versions:  13.0.0-r3(20:31:46 23/07/2014)(crypt -gtk -serial PYTHON_TARGETS="python2_7")
     Homepage:            http://www.twistedmatrix.com/
     Description:         An asynchronous networking framework written in Python

[1] "progress" /portage/local/layman/progress
lyall@lyalls-pc ~/Source/BitcoinArmory-0.92.1
$ eix --installed psutil
[I] dev-python/psutil
     Available versions:  0.6.1^t 1.2.1^t ~2.0.0^t ~2.1.0^t ~2.1.1^t [m]2.1.1-r1000[1] {doc test PYTHON_ABIS="2.6 2.7 2.7-pypy-2.0 3.2 3.3 3.4 3.5" PYTHON_TARGETS="pypy python2_7 python3_2 python3_3 python3_4"}
     Installed versions:  1.2.1^t(05:01:36 02/04/2014)(PYTHON_TARGETS="python2_7 python3_3 -pypy -pypy2_0 -python2_6 -python3_2")
     Homepage:            https://github.com/giampaolo/psutil https://pypi.python.org/pypi/psutil
     Description:         psutil is a cross-platform library for retrieving information on running processes and system utilization (CPU, memory, disks, network) in Python.

[1] "progress" /portage/local/layman/progress
lyall@lyalls-pc ~/Source/BitcoinArmory-0.92.1
$ eix --installed zope
[I] net-zope/zope-interface
     Available versions:  3.8.0 ~4.0.5^t ~4.1.0^t 4.1.1^t [m]1000[1] {PYTHON_ABIS="2.6 2.7 2.7-jython 2.7-pypy-2.0 3.1 3.2 3.3 3.4 3.5" PYTHON_TARGETS="pypy python2_7 python3_2 python3_3 python3_4"}
     Installed versions:  4.1.1^t(20:07:11 23/07/2014)(PYTHON_TARGETS="python2_7 python3_3 -pypy -python3_2 -python3_4")
     Description:         Wrapper package for net-zope/zope.interface

[1] "progress" /portage/local/layman/progress
lyall@lyalls-pc ~/Source/BitcoinArmory-0.92.1
$ eix --installed swig
[I] dev-lang/swig
     Available versions: 
     (0)    1.3.40-r1^t 2.0.4-r1^t 2.0.8^t 2.0.9^t (~)2.0.10^t (~)2.0.11^t (~)2.0.12^t
     (1)    1.3.40-r2^t
       {ccache doc pcre}
     Installed versions:  2.0.12^t(14:08:57 05/08/2014)(pcre -ccache -doc)
     Homepage:            http://www.swig.org/
     Description:         Simplified Wrapper and Interface Generator

lyall@lyalls-pc ~/Source/BitcoinArmory-0.92.1
$


Any suggestions on what is going wrong? The instructions for building on Linux are virtually non-existent because it is assumed it simply works.
_________________
...Lyall


Last edited by lyallp on Tue Aug 19, 2014 11:12 am; edited 1 time in total
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Tue Aug 19, 2014 11:12 am    Post subject: Reply with quote

Sorted.

Assuming you have 'app-arch/snappy' installed.

The makefile in cppForSwig does not include a -lsnappy in the link of _CppBlockUtils.so

so, to avoid changing source...instead of
Code:
make
use
Code:
LDLIBS="-lsnappy" make


and, to run ArmoryQt.py, use
Code:
python2 ArmoryQt.py
as the python is not compatible with Python 3.
_________________
...Lyall
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum