Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] dmesg shown in tty
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ShiroiKuma
n00b
n00b


Joined: 09 Nov 2012
Posts: 40
Location: Japan

PostPosted: Thu Aug 07, 2014 12:25 pm    Post subject: [solved] dmesg shown in tty Reply with quote

I've got a new gentoo system installed yesterday and booting a systemd system via grub2 (efi). No problems major problems so far but one confusing one... once my login prompt appears in tty0, the output of dmesg is still popping up. For example instead of
Code:
tux login:
I'm seeing
Code:
nf_conntrack: automatic helper assignment is deprecated and it will be removed soon
and then a bit later one regarding kworker, right over where my command line prompt is/was.

I've never seen this on a system before. Have I missed a fundamental step?

I've tried searching but perhaps using the wrong terminology. I've been trying to find why dmesg is outputting to framebuffer, but nothing helpful so far.

Any ideas?

Edit:

Maybe this from the systemd page... console/tty/framebuffer are all the same thing?

Quote:
When not using quiet option, you could get some messages overwriting consoles, that is caused by kernel configuration (see man 5 proc and look for /proc/sys/kernel/printk). To tweak it you can pass the loglevel=5 boot parameter to the kernel (or a lower value like 1).


Last edited by ShiroiKuma on Thu Aug 07, 2014 12:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
wraeth
Developer
Developer


Joined: 08 May 2007
Posts: 71
Location: Australia

PostPosted: Thu Aug 07, 2014 12:38 pm    Post subject: Reply with quote

This information is being printed out by the kernels 'printk' function. You can disable this for normal booting by appending the 'quiet' option to your kernel command line.

To do this in GRUB2, you need to edit the file /etc/default/grub to contain
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"

Once that's done, you need to regenerate your GRUB configuration file with
Code:
mount /boot   # only needed if you you have a separate /boot partition
grub2-mkconfig -o /boot/grub/grub.cfg

Adding it to this variable, as opposed to GRUB_CMDLINE_LINUX means thatt the printk output is disabled for normal boots, but the 'quiet' option isn't added to GRUB's recovery boot options in case you need the information to help you troubleshoot an issue.
Back to top
View user's profile Send private message
ShiroiKuma
n00b
n00b


Joined: 09 Nov 2012
Posts: 40
Location: Japan

PostPosted: Thu Aug 07, 2014 12:42 pm    Post subject: Reply with quote

Thanks Wraeth, I finally found it though. I spend an hour looking, make a post and then find the solution 5 - 10 minutes after making a post.

Now I've learnt what quiet actually does. :-)
Back to top
View user's profile Send private message
wraeth
Developer
Developer


Joined: 08 May 2007
Posts: 71
Location: Australia

PostPosted: Thu Aug 07, 2014 1:57 pm    Post subject: Reply with quote

Glad you got this sorted, and enjoy your new system! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum