Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GK107 HDMI Audio via intel-snd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Progman3K
l33t
l33t


Joined: 03 Jan 2004
Posts: 668

PostPosted: Thu Aug 07, 2014 6:47 pm    Post subject: GK107 HDMI Audio via intel-snd Reply with quote

Hi,

I have a stable amd64 system. It is being booted by a rescuecd, which I then request boot an on-disk kernel because I haven't been able to get the stub-efi kernel working yet :-(
Whether or not this is what is causing the no-soundcard problem, I am not sure, so keep it in mind.

The system contains the following hardware (I omitted some devices that are working OK to shorten the listing)

Code:
lspci -v
Quote:
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
Subsystem: ASUSTeK Computer Inc. Device 8534
Flags: bus master, fast devsel, latency 0
Capabilities: [e0] Vendor Specific Information: Len=0c <?>
lspci: Unable to load libkmod resources: error -12

00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
Subsystem: ASUSTeK Computer Inc. Device 8534
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at f721a000 (64-bit, non-prefetchable) [size=16]
Capabilities: [50] Power Management version 3
Capabilities: [8c] MSI: Enable- Count=1/1 Maskable- 64bit+

00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8576
Flags: fast devsel, IRQ 7
Memory at f7210000 (64-bit, non-prefetchable) [disabled] [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel

00:1f.0 ISA bridge: Intel Corporation C220 Series Chipset Family H81 Express LPC Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Flags: bus master, medium devsel, latency 0
Capabilities: [e0] Vendor Specific Information: Len=0c <?>

00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Flags: medium devsel, IRQ 4
Memory at f7215000 (64-bit, non-prefetchable) [size=256]
I/O ports at f000 [size=32]

01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GTX 650] (rev a1) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 8439
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
Expansion ROM at f7000000 [disabled] [size=512K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Capabilities: [900] #19
Kernel driver in use: nouveau

01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)
Subsystem: ASUSTeK Computer Inc. Device 8439
Flags: bus master, fast devsel, latency 0, IRQ 10
Memory at f7080000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00


From reading other posts, the correct kernel driver to support this configuration should be snd-intel, which is built-in to the kernel but doesn't seem to be enabling the card.

Any ideas?

Thanks in advance.
dmesg has no mention at all of sound devices.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7200

PostPosted: Fri Aug 08, 2014 12:43 am    Post subject: Reply with quote

Why not using lspci -k it answer to that.
Code:
02:00.1 Audio device: NVIDIA Corporation GF110 High Definition Audio Controller (rev a1)
   Subsystem: Micro-Star International Co., Ltd. [MSI] Device 2571
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel

So it's snd_hda_intel
Back to top
View user's profile Send private message
Progman3K
l33t
l33t


Joined: 03 Jan 2004
Posts: 668

PostPosted: Fri Aug 08, 2014 11:48 am    Post subject: Reply with quote

krinn wrote:
Why not using lspci -k it answer to that.


Hi Krinn!

I believed -v gave more detail and didn't know about -k

Here's the output with -k

00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
Subsystem: ASUSTeK Computer Inc. Device 8534
lspci: Unable to load libkmod resources: error -12
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
Kernel driver in use: pcieport
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: xhci_hcd
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
Subsystem: ASUSTeK Computer Inc. Device 8534
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8576
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation C220 Series Chipset Family H81 Express LPC Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8534
01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GTX 650] (rev a1)
Subsystem: ASUSTeK Computer Inc. Device 8439
Kernel driver in use: nouveau
01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)
Subsystem: ASUSTeK Computer Inc. Device 8439
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
Subsystem: ASUSTeK Computer Inc. Device 8554
Kernel driver in use: r8169

uname -a
Linux milkyway 3.10.25-std400-amd64 #2 SMP Sun Dec 29 08:42:02 UTC 2013 x86_64 Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz GenuineIntel GNU/Linux

eselect kernel list
Available kernel symlink targets:
[1] linux-3.10.25-gentoo *
[2] linux-3.10.32-gentoo
[3] linux-3.12.13-gentoo
[4] linux-3.12.20-gentoo
[5] linux-3.12.21-gentoo-r1
[6] linux-3.14.14-gentoo

pwd
/usr/src/linux

grep -ni snd_hda_intel .config
2261:CONFIG_SND_HDA_INTEL=y

It has to be the boot CD I am using to get EFI working, even though I select BOOT ON-DISK KERNEL, I am not sure how it goes about finding and booting a kernel. It must end up using the kernel on the CD instead which also happens to be v3.10.25
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7200

PostPosted: Sat Aug 09, 2014 10:33 am    Post subject: Reply with quote

3.10.25-std400-amd64 is not 3.10.25-gentoo, so why you doubt?

And to check a config of a running kernel if it has the option.
Code:
modprobe configs (in case the option is set a module)
zcat /proc/config.gz | grep -ni snd_hda_intel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum