Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Optimus and Slim, just get a black screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 642

PostPosted: Sat Aug 09, 2014 10:32 am    Post subject: Optimus and Slim, just get a black screen Reply with quote

Hi,
I've tried to go through as many tutorials on this as I can (https://forums.gentoo.org/viewtopic-t-959568-highlight-optimus.html), but to no avail. As soon as I switch to the new Xorg file I get a black screen. If anyone's got an ideas I'd be grateful. I've emerged all of the packages

- Kernel 3.9.x (if the kernel is not at least a 3.9.0 it will not work)
- Xorg version 1.13.4 or higher (Tested on 1.13.4 and 1.14.1 version)
- xrandr 1.4.0
- nvidia drivers 319.12 or higher (Tested with the 319.17 version)

I've put this in the make.conf VIDEO_CARDS="intel nvidia modesetting"

Here's my lspci
Quote:
[00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M] (rev a1)
03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
04:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)


My xorg.conf is;
Quote:

Section "ServerLayout"
Identifier "layout"
Screen 0 "nvidia"
Inactive "intel"
EndSection

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "nvidia"
Device "nvidia"
# Uncomment this line if your computer has no display devices connected to
# the NVIDIA GPU. Leave it commented if you have display devices
# connected to the NVIDIA GPU that you would like to use.
#Option "UseDisplayDevice" "none"
EndSection

Section "Device"
Identifier "intel"
Driver "modesetting"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "intel"
Device "intel"
EndSection


and the .xinitrc in my user's home directory is this
Quote:

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto


I've tried starting this through /etc/init.d/xdm start (as root) and startx (as user) ; both result in a black screen.

Here's my xorg.conf
Quote:
[ 6640.826]
X.Org X Server 1.15.0
Release Date: 2013-12-27
[ 6640.827] X Protocol Version 11, Revision 0
[ 6640.827] Build Operating System: Linux 3.12.21-gentoo-r1 x86_64 Gentoo
[ 6640.827] Current Operating System: Linux Columbian 3.12.21-gentoo-r1 #10 SMP Tue Jul 22 14:06:44 BST 2014 x86_64
[ 6640.827] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.12.21-gentoo-r1 root=/dev/sda2 ro
[ 6640.827] Build Date: 24 June 2014 08:47:14AM
[ 6640.827]
[ 6640.827] Current version of pixman: 0.32.4
[ 6640.827] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 6640.827] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 6640.827] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 9 11:24:53 2014
[ 6640.827] (==) Using config file: "/etc/X11/xorg.conf"
[ 6640.827] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 6640.827] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 6640.827] (==) ServerLayout "layout"
[ 6640.827] (**) |-->Screen "nvidia" (0)
[ 6640.827] (**) | |-->Monitor "<default monitor>"
[ 6640.827] (**) | |-->Device "nvidia"
[ 6640.827] (==) No monitor specified for screen "nvidia".
Using a default monitor configuration.
[ 6640.827] (**) |-->Inactive Device "intel"
[ 6640.827] (==) Automatically adding devices
[ 6640.827] (==) Automatically enabling devices
[ 6640.827] (==) Automatically adding GPU devices
[ 6640.827] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc/".
[ 6640.827] Entry deleted from font path.
[ 6640.827] (Run 'mkfontdir' on "/usr/share/fonts/misc/").
[ 6640.827] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[ 6640.827] Entry deleted from font path.
[ 6640.827] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 6640.827] Entry deleted from font path.
[ 6640.827] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 6640.827] Entry deleted from font path.
[ 6640.827] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 6640.827] Entry deleted from font path.
[ 6640.827] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 6640.827] (==) FontPath set to:
/usr/share/fonts/100dpi/
[ 6640.827] (==) ModulePath set to "/usr/lib64/xorg/modules"
[ 6640.827] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 6640.827] (II) Loader magic: 0x807c60
[ 6640.827] (II) Module ABI versions:
[ 6640.827] X.Org ANSI C Emulation: 0.4
[ 6640.827] X.Org Video Driver: 15.0
[ 6640.827] X.Org XInput driver : 20.0
[ 6640.827] X.Org Server Extension : 8.0
[ 6640.828] (II) xfree86: Adding drm device (/dev/dri/card1)
[ 6640.828] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 6640.829] (--) PCI:*(0:0:2:0) 8086:0166:1043:124d rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[ 6640.829] (--) PCI: (0:1:0:0) 10de:1140:1043:223a rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[ 6640.829] Initializing built-in extension Generic Event Extension
[ 6640.829] Initializing built-in extension SHAPE
[ 6640.829] Initializing built-in extension MIT-SHM
[ 6640.829] Initializing built-in extension XInputExtension
[ 6640.829] Initializing built-in extension XTEST
[ 6640.829] Initializing built-in extension BIG-REQUESTS
[ 6640.829] Initializing built-in extension SYNC
[ 6640.829] Initializing built-in extension XKEYBOARD
[ 6640.829] Initializing built-in extension XC-MISC
[ 6640.829] Initializing built-in extension XINERAMA
[ 6640.829] Initializing built-in extension XFIXES
[ 6640.829] Initializing built-in extension RENDER
[ 6640.829] Initializing built-in extension RANDR
[ 6640.829] Initializing built-in extension COMPOSITE
[ 6640.829] Initializing built-in extension DAMAGE
[ 6640.829] Initializing built-in extension MIT-SCREEN-SAVER
[ 6640.829] Initializing built-in extension DOUBLE-BUFFER
[ 6640.829] Initializing built-in extension RECORD
[ 6640.829] Initializing built-in extension DPMS
[ 6640.829] Initializing built-in extension Present
[ 6640.829] Initializing built-in extension DRI3
[ 6640.829] Initializing built-in extension X-Resource
[ 6640.829] Initializing built-in extension XVideo
[ 6640.829] Initializing built-in extension XVideo-MotionCompensation
[ 6640.829] Initializing built-in extension XFree86-VidModeExtension
[ 6640.829] Initializing built-in extension XFree86-DGA
[ 6640.829] Initializing built-in extension XFree86-DRI
[ 6640.829] Initializing built-in extension DRI2
[ 6640.829] (II) LoadModule: "glx"
[ 6640.830] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[ 6640.842] (II) Module glx: vendor="NVIDIA Corporation"
[ 6640.842] compiled for 4.0.2, module version = 1.0.0
[ 6640.842] Module class: X.Org Server Extension
[ 6640.842] (II) NVIDIA GLX Module 340.24 Wed Jul 2 15:04:31 PDT 2014
[ 6640.842] Loading extension GLX
[ 6640.842] (II) LoadModule: "nvidia"
[ 6640.842] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[ 6640.843] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 6640.843] compiled for 4.0.2, module version = 1.0.0
[ 6640.843] Module class: X.Org Video Driver
[ 6640.843] (II) LoadModule: "modesetting"
[ 6640.843] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[ 6640.843] (II) Module modesetting: vendor="X.Org Foundation"
[ 6640.843] compiled for 1.15.0, module version = 0.8.1
[ 6640.843] Module class: X.Org Video Driver
[ 6640.843] ABI class: X.Org Video Driver, version 15.0
[ 6640.843] (II) NVIDIA dlloader X Driver 340.24 Wed Jul 2 14:42:23 PDT 2014
[ 6640.843] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 6640.843] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 6640.843] (++) using VT number 7

[ 6640.846] (II) Loading sub module "fb"
[ 6640.846] (II) LoadModule: "fb"
[ 6640.846] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 6640.847] (II) Module fb: vendor="X.Org Foundation"
[ 6640.847] compiled for 1.15.0, module version = 1.0.0
[ 6640.847] ABI class: X.Org ANSI C Emulation, version 0.4
[ 6640.847] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 6640.847] (II) Loading sub module "wfb"
[ 6640.847] (II) LoadModule: "wfb"
[ 6640.847] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[ 6640.847] (II) Module wfb: vendor="X.Org Foundation"
[ 6640.847] compiled for 1.15.0, module version = 1.0.0
[ 6640.847] ABI class: X.Org ANSI C Emulation, version 0.4
[ 6640.847] (II) Loading sub module "ramdac"
[ 6640.847] (II) LoadModule: "ramdac"
[ 6640.847] (II) Module "ramdac" already built-in
[ 6640.847] (II) modesetting(1): using drv /dev/dri/card0
[ 6640.847] (II) modesetting(G0): using drv /dev/dri/card0
[ 6640.847] (EE) Screen 1 deleted because of no matching config section.
[ 6640.847] (II) UnloadModule: "modesetting"
[ 6640.847] (II) NVIDIA(0): Creating default Display subsection in Screen section
"nvidia" for depth/fbbpp 24/32
[ 6640.847] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 6640.847] (==) NVIDIA(0): RGB weight 888
[ 6640.847] (==) NVIDIA(0): Default visual is TrueColor
[ 6640.847] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 6640.848] (**) NVIDIA(0): Enabling 2D acceleration
[ 6640.972] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20130102)
[ 6640.972] (II) NVIDIA(0): NVIDIA GPU GeForce GT 710M (GF117) at PCI:1:0:0 (GPU-0)
[ 6640.973] (--) NVIDIA(0): Memory: 1048576 kBytes
[ 6640.973] (--) NVIDIA(0): VideoBIOS: 75.17.5e.00.05
[ 6640.973] (II) NVIDIA(0): Detected PCI Express Link width: 8X
[ 6640.973] (--) NVIDIA(0): Valid display device(s) on GeForce GT 710M at PCI:1:0:0
[ 6640.973] (--) NVIDIA(0): none
[ 6640.973] (II) NVIDIA(0): Validated MetaModes:
[ 6640.973] (II) NVIDIA(0): "NULL"
[ 6640.973] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[ 6640.973] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[ 6640.973] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[ 6640.973] (==) modesetting(G0): Depth 24, (==) framebuffer bpp 32
[ 6640.973] (==) modesetting(G0): RGB weight 888
[ 6640.973] (==) modesetting(G0): Default visual is TrueColor
[ 6640.973] (II) modesetting(G0): ShadowFB: preferred YES, enabled YES
[ 6640.973] (II) modesetting(G0): Output LVDS-1-0 has no monitor section
[ 6640.974] (II) modesetting(G0): Output VGA-1-0 has no monitor section
[ 6640.975] (II) modesetting(G0): Output HDMI-1-0 has no monitor section
[ 6640.975] (II) modesetting(G0): Output DisplayPort-1-0 has no monitor section
[ 6640.975] (II) modesetting(G0): EDID for output LVDS-1-0
[ 6640.975] (II) modesetting(G0): Manufacturer: CMO Model: 15a7 Serial#: 0
[ 6640.975] (II) modesetting(G0): Year: 2010 Week: 31
[ 6640.975] (II) modesetting(G0): EDID Version: 1.3
[ 6640.975] (II) modesetting(G0): Digital Display Input
[ 6640.975] (II) modesetting(G0): Max Image Size [cm]: horiz.: 35 vert.: 19
[ 6640.975] (II) modesetting(G0): Gamma: 2.20
[ 6640.975] (II) modesetting(G0): No DPMS capabilities specified
[ 6640.975] (II) modesetting(G0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[ 6640.975] (II) modesetting(G0): First detailed timing is preferred mode
[ 6640.975] (II) modesetting(G0): redX: 0.617 redY: 0.340 greenX: 0.320 greenY: 0.598
[ 6640.975] (II) modesetting(G0): blueX: 0.160 blueY: 0.084 whiteX: 0.313 whiteY: 0.329
[ 6640.975] (II) modesetting(G0): Manufacturer's mask: 0
[ 6640.975] (II) modesetting(G0): Supported detailed timing:
[ 6640.975] (II) modesetting(G0): clock: 69.3 MHz Image Size: 344 x 193 mm
[ 6640.975] (II) modesetting(G0): h_active: 1366 h_sync: 1382 h_sync_end 1416 h_blank_end 1466 h_border: 0
[ 6640.975] (II) modesetting(G0): v_active: 768 v_sync: 770 v_sync_end 776 v_blanking: 788 v_border: 0
[ 6640.975] (II) modesetting(G0): N156BGE-L21
[ 6640.975] (II) modesetting(G0): CMO
[ 6640.975] (II) modesetting(G0): N156BGE-L21
[ 6640.975] (II) modesetting(G0): EDID (in hex):
[ 6640.975] (II) modesetting(G0): 00ffffffffffff000dafa71500000000
[ 6640.975] (II) modesetting(G0): 1f140103802313780a00259e57529929
[ 6640.975] (II) modesetting(G0): 15505400000001010101010101010101
[ 6640.975] (II) modesetting(G0): 010101010101121b5664500014301022
[ 6640.975] (II) modesetting(G0): 260058c110000018000000fe004e3135
[ 6640.975] (II) modesetting(G0): 364247452d4c32310a20000000fe0043
[ 6640.975] (II) modesetting(G0): 4d4f0a202020202020202020000000fe
[ 6640.975] (II) modesetting(G0): 004e3135364247452d4c32310a200095
[ 6640.975] (II) modesetting(G0): Printing probed modes for output LVDS-1-0
[ 6640.975] (II) modesetting(G0): Modeline "1366x768"x60.0 69.30 1366 1382 1416 1466 768 770 776 788 -hsync -vsync (47.3 kHz eP)
[ 6640.975] (II) modesetting(G0): Modeline "1024x768"x120.1 133.47 1024 1100 1212 1400 768 768 770 794 doublescan -hsync +vsync (95.3 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "1024x768"x60.0 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync (48.4 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "960x720"x120.0 117.00 960 1024 1128 1300 720 720 722 750 doublescan -hsync +vsync (90.0 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "928x696"x120.1 109.15 928 976 1088 1264 696 696 698 719 doublescan -hsync +vsync (86.4 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "896x672"x120.0 102.40 896 960 1060 1224 672 672 674 697 doublescan -hsync +vsync (83.7 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "800x600"x120.0 81.00 800 832 928 1080 600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "800x600"x60.3 40.00 800 840 968 1056 600 601 605 628 +hsync +vsync (37.9 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "800x600"x56.2 36.00 800 824 896 1024 600 601 603 625 +hsync +vsync (35.2 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "700x525"x120.0 61.00 700 744 820 940 525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "640x512"x120.0 54.00 640 664 720 844 512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "640x480"x120.0 54.00 640 688 744 900 480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "640x480"x59.9 25.18 640 656 752 800 480 490 492 525 -hsync -vsync (31.5 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "512x384"x120.0 32.50 512 524 592 672 384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "400x300"x120.6 20.00 400 420 484 528 300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "400x300"x112.7 18.00 400 412 448 512 300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
[ 6640.975] (II) modesetting(G0): Modeline "320x240"x120.1 12.59 320 328 376 400 240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
[ 6640.977] (II) modesetting(G0): EDID for output VGA-1-0
[ 6640.977] (II) modesetting(G0): EDID for output HDMI-1-0
[ 6640.977] (II) modesetting(G0): EDID for output DisplayPort-1-0
[ 6640.977] (II) modesetting(G0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[ 6640.977] (==) modesetting(G0): DPI set to (96, 96)
[ 6640.977] (II) Loading sub module "fb"
[ 6640.977] (II) LoadModule: "fb"
[ 6640.977] (II) Loading /usr/lib64/xorg/modules/libfb.so
[ 6640.977] (II) Module fb: vendor="X.Org Foundation"
[ 6640.977] compiled for 1.15.0, module version = 1.0.0
[ 6640.977] ABI class: X.Org ANSI C Emulation, version 0.4
[ 6640.977] (II) Loading sub module "shadow"
[ 6640.977] (II) LoadModule: "shadow"
[ 6640.977] (II) Loading /usr/lib64/xorg/modules/libshadow.so
[ 6640.978] (II) Module shadow: vendor="X.Org Foundation"
[ 6640.978] compiled for 1.15.0, module version = 1.1.0
[ 6640.978] ABI class: X.Org ANSI C Emulation, version 0.4
[ 6640.978] (--) Depth 24 pixmap format is 32 bpp
[ 6640.978] (==) modesetting(G0): Backing store enabled
[ 6640.978] (==) modesetting(G0): Silken mouse enabled
[ 6640.978] (II) modesetting(G0): RandR 1.2 enabled, ignore the following RandR disabled message.
[ 6640.978] (==) modesetting(G0): DPMS enabled
[ 6641.318] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[ 6641.318] (II) NVIDIA: access.
[ 6641.321] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[ 6641.321] (II) NVIDIA(0): may not be running or the "AcpidSocketPath" X
[ 6641.321] (II) NVIDIA(0): configuration option may not be set correctly. When the
[ 6641.321] (II) NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
[ 6641.321] (II) NVIDIA(0): try to use it to receive ACPI event notifications. For
[ 6641.321] (II) NVIDIA(0): details, please see the "ConnectToAcpid" and
[ 6641.321] (II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
[ 6641.321] (II) NVIDIA(0): Config Options in the README.
[ 6641.322] (II) NVIDIA(0): Setting mode "NULL"
[ 6641.322] (EE) NVIDIA(0): Failed to initiate mode change.
[ 6641.322] (EE) NVIDIA(0): Failed to complete mode change
[ 6641.334] (II) NVIDIA(0): Built-in logo is bigger than the screen.
[ 6641.334] Loading extension NV-GLX
[ 6641.339] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 6641.339] (==) NVIDIA(0): Backing store enabled
[ 6641.339] (==) NVIDIA(0): Silken mouse enabled
[ 6641.339] (==) NVIDIA(0): DPMS enabled
[ 6641.339] Loading extension NV-CONTROL
[ 6641.339] (II) Loading sub module "dri2"
[ 6641.339] (II) LoadModule: "dri2"
[ 6641.339] (II) Module "dri2" already built-in
[ 6641.339] (II) NVIDIA(0): [DRI2] Setup complete
[ 6641.339] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 6641.339] (--) RandR disabled
[ 6641.346] (II) Initializing extension GLX
[ 6641.347] (II) modesetting(G0): Damage tracking initialized
[ 6641.394] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[ 6641.394] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[ 6641.394] (II) LoadModule: "evdev"
[ 6641.394] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[ 6641.394] (II) Module evdev: vendor="X.Org Foundation"
[ 6641.394] compiled for 1.15.0, module version = 2.8.2
[ 6641.394] Module class: X.Org XInput Driver
[ 6641.394] ABI class: X.Org XInput driver, version 20.0
[ 6641.394] (II) Using input driver 'evdev' for 'Power Button'
[ 6641.394] (**) Power Button: always reports core events
[ 6641.394] (**) evdev: Power Button: Device: "/dev/input/event2"
[ 6641.394] (--) evdev: Power Button: Vendor 0 Product 0x1
[ 6641.394] (--) evdev: Power Button: Found keys
[ 6641.394] (II) evdev: Power Button: Configuring as keyboard
[ 6641.394] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[ 6641.394] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[ 6641.394] (**) Option "xkb_rules" "evdev"
[ 6641.394] (**) Option "xkb_model" "pc104"
[ 6641.394] (**) Option "xkb_layout" "us"
[ 6641.420] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[ 6641.420] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 6641.420] (II) Using input driver 'evdev' for 'Video Bus'
[ 6641.420] (**) Video Bus: always reports core events
[ 6641.420] (**) evdev: Video Bus: Device: "/dev/input/event4"
[ 6641.420] (--) evdev: Video Bus: Vendor 0 Product 0x6
[ 6641.420] (--) evdev: Video Bus: Found keys
[ 6641.420] (II) evdev: Video Bus: Configuring as keyboard
[ 6641.420] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input4/event4"
[ 6641.420] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[ 6641.420] (**) Option "xkb_rules" "evdev"
[ 6641.420] (**) Option "xkb_model" "pc104"
[ 6641.420] (**) Option "xkb_layout" "us"
[ 6641.421] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[ 6641.421] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[ 6641.421] (II) Using input driver 'evdev' for 'Video Bus'
[ 6641.421] (**) Video Bus: always reports core events
[ 6641.421] (**) evdev: Video Bus: Device: "/dev/input/event3"
[ 6641.421] (--) evdev: Video Bus: Vendor 0 Product 0x6
[ 6641.421] (--) evdev: Video Bus: Found keys
[ 6641.421] (II) evdev: Video Bus: Configuring as keyboard
[ 6641.421] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:03/LNXVIDEO:00/input/input3/event3"
[ 6641.421] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[ 6641.421] (**) Option "xkb_rules" "evdev"
[ 6641.421] (**) Option "xkb_model" "pc104"
[ 6641.421] (**) Option "xkb_layout" "us"
[ 6641.421] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[ 6641.421] (II) No input driver specified, ignoring this device.
[ 6641.421] (II) This device may have been added with another device file.
[ 6641.421] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[ 6641.421] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[ 6641.421] (II) Using input driver 'evdev' for 'Sleep Button'
[ 6641.421] (**) Sleep Button: always reports core events
[ 6641.421] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[ 6641.421] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[ 6641.421] (--) evdev: Sleep Button: Found keys
[ 6641.421] (II) evdev: Sleep Button: Configuring as keyboard
[ 6641.421] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input1/event1"
[ 6641.422] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[ 6641.422] (**) Option "xkb_rules" "evdev"
[ 6641.422] (**) Option "xkb_model" "pc104"
[ 6641.422] (**) Option "xkb_layout" "us"
[ 6641.422] (II) config/udev: Adding drm device (/dev/dri/card1)
[ 6641.422] (II) config/udev: Adding drm device (/dev/dri/card0)
[ 6641.422] (II) config/udev: Adding input device USB2.0 HD UVC WebCam (/dev/input/event7)
[ 6641.422] (**) USB2.0 HD UVC WebCam: Applying InputClass "evdev keyboard catchall"
[ 6641.422] (II) Using input driver 'evdev' for 'USB2.0 HD UVC WebCam'
[ 6641.422] (**) USB2.0 HD UVC WebCam: always reports core events
[ 6641.422] (**) evdev: USB2.0 HD UVC WebCam: Device: "/dev/input/event7"
[ 6641.422] (--) evdev: USB2.0 HD UVC WebCam: Vendor 0x4f2 Product 0xb40a
[ 6641.422] (--) evdev: USB2.0 HD UVC WebCam: Found keys
[ 6641.422] (II) evdev: USB2.0 HD UVC WebCam: Configuring as keyboard
[ 6641.422] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/input/input14/event7"
[ 6641.422] (II) XINPUT: Adding extended input device "USB2.0 HD UVC WebCam" (type: KEYBOARD, id 10)
[ 6641.422] (**) Option "xkb_rules" "evdev"
[ 6641.422] (**) Option "xkb_model" "pc104"
[ 6641.422] (**) Option "xkb_layout" "us"
[ 6641.423] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[ 6641.423] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[ 6641.423] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[ 6641.423] (**) AT Translated Set 2 keyboard: always reports core events
[ 6641.423] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[ 6641.423] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[ 6641.423] (--) evdev: AT Translated Set 2 keyboard: Found keys
[ 6641.423] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[ 6641.423] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input5/event5"
[ 6641.423] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[ 6641.423] (**) Option "xkb_rules" "evdev"
[ 6641.423] (**) Option "xkb_model" "pc104"
[ 6641.423] (**) Option "xkb_layout" "us"
[ 6641.424] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event6)
[ 6641.424] (**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"
[ 6641.424] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[ 6641.424] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
[ 6641.424] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad"
[ 6641.424] (II) LoadModule: "synaptics"
[ 6641.424] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[ 6641.424] (II) Module synaptics: vendor="X.Org Foundation"
[ 6641.424] compiled for 1.15.0, module version = 1.7.4
[ 6641.424] Module class: X.Org XInput Driver
[ 6641.424] ABI class: X.Org XInput driver, version 20.0
[ 6641.424] (II) Using input driver 'synaptics' for 'ETPS/2 Elantech Touchpad'
[ 6641.424] (**) ETPS/2 Elantech Touchpad: always reports core events
[ 6641.424] (**) Option "Device" "/dev/input/event6"
[ 6641.450] (II) synaptics: ETPS/2 Elantech Touchpad: found clickpad property
[ 6641.450] (--) synaptics: ETPS/2 Elantech Touchpad: x-axis range 0 - 3249 (res 33)
[ 6641.450] (--) synaptics: ETPS/2 Elantech Touchpad: y-axis range 0 - 2223 (res 33)
[ 6641.450] (--) synaptics: ETPS/2 Elantech Touchpad: pressure range 0 - 255
[ 6641.450] (--) synaptics: ETPS/2 Elantech Touchpad: finger width range 0 - 15
[ 6641.450] (--) synaptics: ETPS/2 Elantech Touchpad: buttons: left double triple
[ 6641.450] (--) synaptics: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
[ 6641.450] (**) Option "EmulateTwoFingerMinZ" "40"
[ 6641.450] (**) Option "EmulateTwoFingerMinW" "8"
[ 6641.450] (**) Option "VertEdgeScroll" "on"
[ 6641.450] (**) Option "HorizEdgeScroll" "on"
[ 6641.450] (**) Option "VertTwoFingerScroll" "on"
[ 6641.450] (**) Option "HorizTwoFingerScroll" "on"
[ 6641.450] (**) Option "TapButton1" "1"
[ 6641.450] (**) Option "TapButton2" "3"
[ 6641.450] (**) Option "TapButton3" "2"
[ 6641.450] (**) Option "CircularScrolling" "on"
[ 6641.450] (**) Option "CircScrollTrigger" "2"
[ 6641.450] (**) Option "PalmDetect" "1"
[ 6641.450] (**) Option "CoastingSpeed" "0"
[ 6641.450] (**) Option "TapAndDragGesture" "1"
[ 6641.450] (**) Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
[ 6641.450] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[ 6641.450] (**) ETPS/2 Elantech Touchpad: always reports core events
[ 6641.460] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input13/event6"
[ 6641.460] (II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD, id 12)
[ 6641.460] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MinSpeed is now constant deceleration 2.5
[ 6641.460] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MaxSpeed is now 1.75
[ 6641.460] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) AccelFactor is now 0.051
[ 6641.460] (**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[ 6641.460] (**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 1
[ 6641.460] (**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[ 6641.460] (**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[ 6641.460] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[ 6641.460] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)
[ 6641.460] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"


If anyone's got any ideas, I'd be really grateful. I've generated a EDID file, I'm not sure how I should use it.

My laptop is a ASUS X552C,

Thanks,
_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Aug 09, 2014 1:07 pm    Post subject: Reply with quote

I highly recommend that you use the unstable nvidia-driver + latest unstable gentoo-sources. As i used for years nvidia on linux a newer version has some hidden bug fixes sometimes which maybe just solves your problem.

Best way is to try around until it works. with the binary drivers there is not really a better solution sometimes.
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 739

PostPosted: Sat Aug 09, 2014 8:57 pm    Post subject: Reply with quote

I tried slim but dropped it in favour of lightdm.

Not sure the xrandr commands will work in .xinitrc. I have those commands in a separate script and it is executed during lightdm startup, i.e. before user login.
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 642

PostPosted: Sun Aug 10, 2014 11:15 am    Post subject: Reply with quote

Could you explain how you ran that from a script in lightdm please? Also, does the xorg.conf look right? [Edit] actually don't want to use lightDM due to all the Gnome dependencies.

I think there's something deeper going on as the error
40.973] (WW) NVIDIA(0): Unable to get display device for DPI computation.

[ 6641.322] (EE) NVIDIA(0): Failed to initiate mode change.
[ 6641.322] (EE) NVIDIA(0): Failed to complete mode change
[ 6641.334] (II) NVIDIA(0): Built-in logo is bigger than the screen.
_________________
Intel 2.2 Core 2 Duo, 4Gb Ram, 320GB Sata Drive and Nvidia card.
Back to top
View user's profile Send private message
cyberjun
Apprentice
Apprentice


Joined: 06 Nov 2005
Posts: 293

PostPosted: Sun Aug 10, 2014 12:28 pm    Post subject: Reply with quote

Hi,
Check this thread: https://forums.gentoo.org/viewtopic-t-997018-highlight-optimus.html

The nvidia drivers errors you mention can be ignored. They are not the cause of black screen.

--cyberjun
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 739

PostPosted: Mon Aug 11, 2014 8:55 pm    Post subject: Reply with quote

Your xorg.conf looks nearly like mine. The Screen section has two additions:
Code:

    Option "AllowEmptyInitialConfiguration"
    Option "UseDisplayDevice" "none"

/etc/lightdm/lightdm.conf:
Code:

display-setup-script=/usr/bin/lightdmxrandr

and finally, /usr/bin/lightdmxrandr:
Code:

#!/bin/sh
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

Yes, it looks like I perused the link posted by cyberjun :)
Back to top
View user's profile Send private message
Atmmac
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2013
Posts: 130
Location: Watertown, MA

PostPosted: Wed Aug 13, 2014 3:12 pm    Post subject: Reply with quote

If you want to use the optimus functionality I would recommend the following... I tried the same tutorial you referenced and spent weeks trying to get it to work.


Go unstable on the nvidia drivers.

Update your kernel to at least 3.12.x ( i had problems on 3.10.x)

Remove all the xrandr config adjustments you made.

delete your xorg.conf

adjust your make.conf to have the following

VIDEO_CARDS="intel nvidia"

add a global bbswitch use flag as well.

do an emerge -auDN @world


emerge bbswitch and bumblebee if it doesn't get pulled in with the flags

make sure eselect opengl list shows xorg as selected and not nvidia.

add yourself to the video and bumblebee groups.

Restart the machine and try an optirun glxgears

You should be golden. In the future also pull in primus with the overlay. The performance is much better.


Good luck.
Back to top
View user's profile Send private message
lexming
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2007
Posts: 123
Location: Barcelona

PostPosted: Wed Oct 01, 2014 12:52 pm    Post subject: Reply with quote

There is a little trick in slim to execute xrandr before login. The command used by slim to take screenshots can be changed to any other command. Therefore, it is possible to put the two xrandr commands that activate the GPU off-loading in a small script and change the screenshot_cmd parameter in /etc/slim.conf to execute that script, instead of the screenshot utility. The execution of xrandr will not be automatic of course, but just pressing F11 will bring the screen back to live.

The screenshot_cmd in /etc/slim.conf
Code:
[...]
screenshot_cmd      /etc/X11/xinit/xinitrc.d/94-xrandr
[...]


My /etc/X11/xinit/xinitrc.d/94-xrandr file
Code:
#!/bin/sh
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum