Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HPLIP stopped recognizing my LaserJet 2100
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Lebkoungcity
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2008
Posts: 125
Location: Lebkoungcity (='Gingerbreadcity' =Nuremberg)

PostPosted: Sat Aug 09, 2014 10:49 am    Post subject: HPLIP stopped recognizing my LaserJet 2100 Reply with quote

Hey everyone out there :wink:

Could anyone tell me why HPLIP stopped to recognize my printer?

Since almost eight years I have a HP LaserJet 2100 connected to my "big" box via some good old-fashioned parallel-port-cable and since then I use HPLIP to make it print. And most of the time it worked like a charm. OK, sometimes after a HPLIP-update the printer stopped to work so I had to remove it from HPLIP and run hp-setup to get it back to work. That was a little bit frustrating but I knew which steps I had to take.

That was always fine - until now: The last time I used the printer was mid-July and I printed flawlessly some hundred pages. But a few days ago when I had to print something the printer didn't react. So I took the steps I knew: I removed the printer from HPLIP with 'hp-setup -r' and wanted to set it up again (I wasn't sure if there had been an update to HPLIP.). But now hp-setup didn't even find the printer. So I tried it with the cups-frontend on http://localhost:631 also with no success. I found out that the module "lp" wasn't loaded and after adding it to /etc/conf.d/modules the printer showed up on cups but not within hp-setup. Trying the address "hp:/par/HP_LaserJet_2100_Series?device=/dev/parport0" in cups gives me a entry in the hp-toolbox and in cups but the printer doesn't print - it just aborts the job. Doing the same with the line "parallel:/dev/lp0" results in a working printer when I choose "HP LaserJet 2100, hpcups 3.14.1 (en)" or "HP LaserJet 2200 pcl3, hpcups 3.14.1 (en)" from the list (btw: I don't see any difference between the both...) just the margins on the page aren't correct. OK I could try to modify the ppd-file to correct it.

But the big question is: Why did this happen? Why does HPLIP/hp-setup not work anymore?

Some info about the system:

Code:
emerge -pv cups hplip

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-print/cups-1.7.3  USE="X acl dbus java pam ssl threads usb -debug -gnutls -kerberos -lprng-compat -python (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="(64) (-32) (-x32)" LINGUAS="-ca -es -fr -it -ja -pt_BR -ru" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild   R    ] net-print/hplip-3.14.1  USE="X hpcups kde libnotify parport (policykit) qt4 scanner snmp -doc -fax -hpijs -libusb0 -minimal -static-ppds" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB


Code:
dmesg | grep -i -e 'parport' -e ppdev -e lp0 -e LaserJet -e '[Ii][Rr][Qq] *7'
[    6.523493] parport_pc 00:09: reported by Plug and Play ACPI
[    6.523559] parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
[    6.550281] parport0: Printer, Hewlett-Packard HP LaserJet 2100 Series
[    6.679033] ppdev: user-space parallel port driver


Code:
lsmod
Module                  Size  Used by
(...)
lp                      8066  0
(...)
ppdev                   5327  0
(...)
parport_pc             27332  1
(...)
parport                26722  3 lp,ppdev,parport_pc




    - net-print/hplip-3.14.1 worked since Wed Jan 29 00:14:32 2014
    - kernel-update from 3.12.21-gentoo-r1 to 3.14.14-gentoo but it does not make any difference which one I boot
    - put "lp" into /etc/conf.d/modules 'cause it wasn't autoloaded anymore
    - compiled the modules belonging to the parallel-port into the kernel (not as modules) - makes no difference
    - synced the portage-tree and run "emerge -auvDN world" to update the system - no difference
    - run "etc-update" and "revdep-rebuild" several times (just in case...) - no difference
    - run "perl-cleaner --reallyall" and "python-updater" (which found some packages an re-emerged them) - no difference
    - emerged net-print/hplip-3.14.6 - no difference
    - experimented with different addresses e.g. "hp:/par/HP_LaserJet_2100_Series?device=/dev/parport0" (which was used until it stopped working) and "parallel:/dev/lp0" (which activates the printer from within cups - with incorrect margins - but not in the hp-toolbox since it doesn't start with "hp:/")


Greetings,
Andy


<edit>
OK, I've done a complete emerge -e just in case - but no effect (except that media-gfx/digikam-3.5.0 fails to compile...).
</edit>
_________________
"The most dangerous world view is the world view of the ones who haven't viewed the world."
Alexander von Humboldt (1769-1859)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum