Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Thinkpad W530 with NVIDIA K2000 gives black screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
samidarko
n00b
n00b


Joined: 10 Aug 2014
Posts: 27

PostPosted: Sun Aug 10, 2014 2:26 pm    Post subject: [SOLVED] Thinkpad W530 with NVIDIA K2000 gives black screen Reply with quote

I'm trying to make work the nvidia-drivers with my graphic card:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K2000M] (rev ff)

uname -a
Linux 3.14.14-gentoo #3 SMP Sun Aug 10 19:00:42 SGT 2014 x86_64 Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz GenuineIntel GNU/Linux

The intel side is working fine but I can't make work the discrete one, the laptop is booting

I find these mesages in dmesg:

[ 8.520759] ACPI Warning: \_SB_.PCI0.PEG_.VID_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20131218/nsarguments-95)
...
NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5


linux kernel configuration
http://dpaste.com/26VTEKY

dmesg
http://dpaste.com/0RPCYJG

Xorg.0.log
http://dpaste.com/320NZJ5

I got the last kernel version, the last UEFI,

Every time I build I do:
make && make modules_install && make install && emerge @module-rebuild

Or:
emerge @x11-module-rebuild

Also tried different xorg.cong configuration, like minimal, nvidia-xconfig generated or any.

Any help would be welcome : )


Last edited by samidarko on Thu May 18, 2017 4:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43178
Location: 56N 3W

PostPosted: Sun Aug 10, 2014 2:45 pm    Post subject: Reply with quote

samidarko,

Welcome to the forums.

You have an Optimus graphics solution. This means that you can use the Intel Graphics on its own, or the Intel and nVidia together but nVidia alone will only give you a blank screen.

Search for Optimus both here and on Wiki
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
samidarko
n00b
n00b


Joined: 10 Aug 2014
Posts: 27

PostPosted: Sun Aug 10, 2014 3:38 pm    Post subject: Reply with quote

Hi Neddy,

I appreciate the answer but I did use this laptop with other linux distribution and I was able to boot on any mode (integrated or discrete or optimus) without any problem and I had confirmation that is possible with Gentoo from the IRC channel #gentoo.

There is a "boostraping" problem you can observe in the dmesg log:

[ 17.777660] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[ 17.803284] NVRM: RmInitAdapter failed! (0x25:0x28:1181)
[ 17.803291] NVRM: rm_init_adapter failed for device bearing minor number 0
[ 17.803310] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5

I'm looking for some help to resolve this problem. I spent many hours since last week-end (I really mean a lot of time), also on #gentoo. I found some resources on some forums, and followed them, but without any luck that's why I'm here.

Some people say it's a bug from ACPI in the kernel, I changed of kernel, some others said it's an irq one (didn try to change this). I'm really running out of ideas.

Anyway thanks again for your help : )

UPDATE
I just rebuilt my kernel with genkernel ... still have the same issue ...
Back to top
View user's profile Send private message
samidarko
n00b
n00b


Joined: 10 Aug 2014
Posts: 27

PostPosted: Mon Aug 11, 2014 8:09 am    Post subject: [solved] Reply with quote

Finally I found some help (again) from IRC #gentoo. Thank you guys, you're really AWSOME!

My working kernel configuration + nvidia driver 343.13 :

http://dpaste.com/3T85Z5Z
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum