Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]LUKS/LVM Better-Initramfs GRUB2 rEFInd
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 09 May 2012
Posts: 32

PostPosted: Fri Aug 15, 2014 5:12 pm    Post subject: [SOLVED]LUKS/LVM Better-Initramfs GRUB2 rEFInd Reply with quote

I've been booting an old kernel version back in the 13.3 series, because it worked. After an overhaul took out those sources and an ati-drivers update, I'm kinda up the creek unless I can figure this out.

-rEFInd has been painless, to my knowledge - it still goes straight into GRUB2, just like I wanted.

-Grub2 still works. It boots into the 13.3 kernel painlessly.

-The same initramfs.cpio.gz works for 13.3.xx, and newer reworkings of such with better-initramfs do so.

On any newer version kernel, dating back to 13.3.(xx+1) I get the following output:
Early console in decompress_kernel

Decompressing Linux... Parsing ELF... done.
Booting the kernel.

And then the thing just stops. The fans power down, we're left with no other signs of life, aside from the specified output still on the screen, for as long as I allow the computer to sit.

Back on in 13.3.xx, this same output doesn't even linger on the screen for a second, with the console just being overtaken with a flicker of hardware checks and detection, and finally the prompt for the LUKS password . From there, things boot as normal on 13.3.xx.

Since I've wiped the sources of 13.3.xx (foolish mistake!) and updated ati-drivers since, Xorg does not function sufficiently.

genkernel-generated initramfs leads to hardware errors and a kernel panic in that hardware detection section. Instead, I've been using the kernel's own bzImage from the 'make && make modules_install' command.

Any ideas? Are there any kernel flags that I'm missing?


Yeah, I removed the framebuffer support from the kernel like a n00b. Putting that back in allowed the thing to boot. Better-initramfs *is* pretty easy to use
Though I think I might explore other options for an initramfs, just because the Aboriginal Linux base for better-initramfs stays pretty static, and I'm still exploring what kind of security flaws that entails.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum