Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Printer HP LaserJet Professional M1212nf_MFP stop print
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Thu Aug 28, 2014 5:13 am    Post subject: Printer HP LaserJet Professional M1212nf_MFP stop print Reply with quote

After driver update my printer Printer HP LaserJet Professional M1212nf_MFP stop print, all jobs failed with state "Filter failed", file /var/log/cups/error_log shows that
Quote:

D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[0]="CUPS_CACHEDIR=/var/cache/cups"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[1]="CUPS_DATADIR=/usr/share/cups"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[2]="CUPS_DOCROOT=/usr/share/cups/html"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[3]="CUPS_FONTPATH=/usr/share/cups/fonts"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[4]="CUPS_REQUESTROOT=/var/spool/cups"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[5]="CUPS_SERVERBIN=/usr/libexec/cups"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[6]="CUPS_SERVERROOT=/etc/cups"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[7]="CUPS_STATEDIR=/run/cups"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[8]="HOME=/var/spool/cups/tmp"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[9]="PATH=/usr/libexec/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[10]="SERVER_ADMIN=root@Gentoo"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[11]="SOFTWARE=CUPS/1.7.3"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[12]="TMPDIR=/var/spool/cups/tmp"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[13]="USER=root"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[14]="CUPS_MAX_MESSAGE=2047"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[15]="CUPS_SERVER=/run/cups/cups.sock"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[16]="CUPS_ENCRYPTION=IfRequested"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[17]="IPP_PORT=631"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[18]="CHARSET=utf-8"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[19]="LANG=en_US.UTF-8"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[20]="PPD=/etc/cups/ppd/HP_LaserJet_Professional_M1212nf_MFP.ppd"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[21]="RIP_MAX_CACHE=128m"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[22]="CONTENT_TYPE=application/vnd.cups-pdf-banner"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[23]="DEVICE_URI=hp:/net/HP_LaserJet_Professional_M1212nf_MFP?ip=192.168.10.103"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[24]="PRINTER_INFO="
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[25]="PRINTER_LOCATION="
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[26]="PRINTER=HP_LaserJet_Professional_M1212nf_MFP"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[27]="PRINTER_STATE_REASONS=none"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[28]="CUPS_FILETYPE=document"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[29]="FINAL_CONTENT_TYPE=application/vnd.cups-raster"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] envp[30]="AUTH_INFO_REQUIRED=none"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] PID 20621 (/usr/libexec/cups/filter/pdftopdf) exited with no errors.
D [28/Aug/2014:03:07:12 +0400] [Job 2497] Start rendering...
D [28/Aug/2014:03:07:12 +0400] [Job 2497] Set job-printer-state-message to "Start rendering...", current level=INFO
D [28/Aug/2014:03:07:12 +0400] [Job 2497] Processing page 1...
D [28/Aug/2014:03:07:12 +0400] [Job 2497] Set job-printer-state-message to "Processing page 1...", current level=INFO
D [28/Aug/2014:03:07:12 +0400] [Job 2497] STATE: +hplip.plugin-error
D [28/Aug/2014:03:07:12 +0400] [Job 2497] prnt/hpcups/HPCupsFilter.cpp 456: m_Job initialization failed with error = 48
D [28/Aug/2014:03:07:12 +0400] [Job 2497] STATE: +connecting-to-device
D [28/Aug/2014:03:07:12 +0400] [Job 2497] PID 20623 (/usr/libexec/cups/filter/hpcups) stopped with status 1.
D [28/Aug/2014:03:07:12 +0400] [Job 2497] Hint: Try setting the LogLevel to "debug" to find out more.
D [28/Aug/2014:03:07:12 +0400] [Job 2497] STATE: -connecting-to-device
D [28/Aug/2014:03:07:12 +0400] [Job 2497] STATE: -media-empty-error,media-jam-error,hplip.plugin-error,cover-open-error,toner-empty-error,other
D [28/Aug/2014:03:07:12 +0400] [Job 2497] ready to print
D [28/Aug/2014:03:07:12 +0400] [Job 2497] PID 20624 (/usr/libexec/cups/backend/hp) exited with no errors.
D [28/Aug/2014:03:07:12 +0400] [Job 2497] Processing page 2...
D [28/Aug/2014:03:07:12 +0400] [Job 2497] Rendering completed
D [28/Aug/2014:03:07:12 +0400] [Job 2497] PID 20622 (/usr/libexec/cups/filter/gstoraster) exited with no errors.
D [28/Aug/2014:03:07:12 +0400] [Job 2497] End of messages
D [28/Aug/2014:03:07:12 +0400] [Job 2497] printer-state=3(idle)
D [28/Aug/2014:03:07:12 +0400] [Job 2497] printer-state-message="Rendering completed"
D [28/Aug/2014:03:07:12 +0400] [Job 2497] printer-state-reasons=none
E [28/Aug/2014:03:12:13 +0400] [Job 2497] Stopping unresponsive job.
E [28/Aug/2014:08:24:08 +0400] [Job 2498] Job stopped due to filter errors; please consult the error_log file for details.
,

reemerging and restart cups, hplip, cups-filters does not help.

Any ideas
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
vasettoo
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2012
Posts: 77

PostPosted: Thu Aug 28, 2014 10:11 am    Post subject: Reply with quote

I use similar MFC - HP M1120 MFP - and its working with the drivers from http://foo2xqx.rkkda.com/. The catch is that after some update to cups-filters its foomatic-filters were boken and I had to change my USE flags for it:
Code:
net-print/cups-filters -foomatic

See also my post on this topic:
https://forums.gentoo.org/viewtopic-t-975378-highlight-foo2zjs.html
Back to top
View user's profile Send private message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Thu Aug 28, 2014 11:37 am    Post subject: Reply with quote

Sorry, I try to use it, but the same error was arise.
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
vasettoo
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2012
Posts: 77

PostPosted: Thu Aug 28, 2014 4:24 pm    Post subject: Reply with quote

Did you remove all of the packages installed by portage prior to the new ones? Drivers in portage may interfere with the ones from http://foo2xqx.rkkda.com/.
Back to top
View user's profile Send private message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Thu Aug 28, 2014 7:43 pm    Post subject: Reply with quote

Unfortunately not, today I try to do that.
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
YuriyRusinov
Apprentice
Apprentice


Joined: 21 Jul 2004
Posts: 208
Location: Saint-Petersburg, Russia

PostPosted: Fri Aug 29, 2014 8:13 pm    Post subject: Reply with quote

I did it, but nothing changes. I install hp using http://wiki.gentoo.org/wiki/HPLIP#Printers_and_Faxes Now I try to manually download hplip-3.14.1-plugin.run from site, make sh hplip-3.14.1-plugin.run, all works fine, but when I try to run hp-testpage, message about missing plugin was arise, I try to (re)install plugin, but test page does not print and the same error "Filter failed" is arisen. Which way I have to install this plugin and where is my error ?
_________________
Best regards,
Yuriy Rusinov.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum