Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201408-15 ] PostgreSQL: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Sat Aug 30, 2014 12:26 am    Post subject: [ GLSA 201408-15 ] PostgreSQL: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PostgreSQL: Multiple vulnerabilities (GLSA 201408-15)
Severity: normal
Exploitable: remote
Date: August 29, 2014
Bug(s): #456080, #463884, #501946
ID: 201408-15

Synopsis

Multiple vulnerabilities have been found in PostgreSQL, the worst
of which may allow remote Denial of Service.


Background

PostgreSQL is an open source object-relational database management
system.


Affected Packages

Package: dev-db/postgresql-server
Vulnerable: < 9.3.3
Unaffected: >= 9.3.3
Unaffected: >= 9.2.7 < 9.2.8
Unaffected: >= 9.1.12 < 9.1.13
Unaffected: >= 9.0.16 < 9.0.17
Unaffected: >= 8.4.20 < 8.4.21
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.


Impact

A remote authenticated attacker may be able to create a Denial of
Service condition, bypass security restrictions, or have other
unspecified impact.


Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL 9.3 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.3.3"
   
All PostgreSQL 9.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.2.7"
   
All PostgreSQL 9.1 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.1.12"
   
All PostgreSQL 9.0 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-9.0.16"
   
All PostgreSQL 8.4 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/postgresql-server-8.4.20"
   


References

CVE-2013-0255
CVE-2013-1899
CVE-2013-1900
CVE-2013-1901
CVE-2014-0060
CVE-2014-0061
CVE-2014-0062
CVE-2014-0063
CVE-2014-0064
CVE-2014-0065
CVE-2014-0066
CVE-2014-2669
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum