Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
UX51VZ overheating
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
treeman1111
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2013
Posts: 77

PostPosted: Sat Aug 30, 2014 9:23 pm    Post subject: UX51VZ overheating Reply with quote

After selling my old desktop and purchasing a new laptop, I was excited to run the laptop with Linux. However, after installing Funtoo, it soon became apparent to me that something was not right. On Windows 8, the laptop's CPU runs around 30 - 40 degrees celsius. On Linux, though, it runs around 65 degrees celsius when idle and at 85+ degrees when in use. I have tried using cpupower, thermald, changing the boot options, and running laptop-mode-tools to little effect. Attached are my configuration files for thermald and laptop-mode, as well as my kernel .config and grub.cfg. Any help is greatly appreciated, as I refuse to run Windows.

/etc/thermald/thermal-conf.xml
Code:

<?xml version="1.0"?>

<!--
use "man thermal-conf.xml" for details
-->

<!-- BEGIN -->
<ThermalConfiguration>
<Platform>
        <Name>Generic X86 Laptop Device</Name>
        <ProductName>*</ProductName>
        <Preference>QUIET</Preference>
        <ThermalSensors>
                <ThermalSensor>
                        <Type>ThermalZone0</Type>
                        <Path>/sys/class/thermal/thermal_zone0/temp</Path>
                        <AsyncCapable>0</AsyncCapable>
                </ThermalSensor>
        </ThermalSensors>
        <ThermalZones>
                <ThermalZone>
                        <Type>Surface</Type>
                        <TripPoints>
                                <TripPoint>
                                        <Temperature>45000</Temperature>
                                        <type>max</type>
                                </TripPoint>
                        </TripPoints>
                </ThermalZone>
        </ThermalZones>
</Platform>


/etc/laptop-mode/conf.d/cpufreq.conf
Code:

.......
CONTROL_CPU_FREQUENCY=1


#
# Legal values are "slowest" for the slowest speed that your
# CPU is able to operate at, "fastest" for the fastest speed,
# "medium" for some value in the middle, or any value listed in
# /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_frequencies.
# The "governor" can be any governor installed on your system, this usually
# includes "ondemand", "conservative", and "performance". The
# "IGNORE_NICE_LOAD" setting specifies that background programs that have
# a low priority ("nice level") should not cause the CPU frequency to
# be increased. (You generally want this to be enabled in battery mode.)
#
BATT_CPU_MAXFREQ=slowest
BATT_CPU_MINFREQ=slowest
BATT_CPU_GOVERNOR=powersave
BATT_CPU_IGNORE_NICE_LOAD=1
LM_AC_CPU_MAXFREQ=slowest
LM_AC_CPU_MINFREQ=slowest
LM_AC_CPU_GOVERNOR=powersave
LM_AC_CPU_IGNORE_NICE_LOAD=1
NOLM_AC_CPU_MAXFREQ=slowest
NOLM_AC_CPU_MINFREQ=slowest
NOLM_AC_CPU_GOVERNOR=powersave
NOLM_AC_CPU_IGNORE_NICE_LOAD=1


#
# Should laptop mode tools control the CPU throttling? This is only useful
# on processors that don't have frequency scaling.
# (Only works when you have /proc/acpi/processor/CPU*/throttling.)
#
# This is only useful on older P4 processors that do not support frequency
# scaling. On such processors, this is the only way to reduce power consumption
# but at the cost of higher performance penalty.
#
# Enable this only if you have a processor that does not support frequency scaling
# On most new processors, you might want to disable it.
#
# Set to 0 to disable.
CONTROL_CPU_THROTTLING=0


#
# Legal values are "maximum" for the maximum (slowest) throttling level,
# "minimum" for minimum (fastest) throttling level, "medium" for a value
# somewhere in the middle (this is usually 50% for P4s), or any value listed
# in /proc/acpi/processor/CPU*/throttling. Be careful when using "maximum":
# this may be _very_ slow (in fact, with P4s it slows down the processor
# by a factor 8).
#
BATT_CPU_THROTTLING=medium
.....


/usr/src/linux/.config:

http://pastebin.com/pZDpEe5P

/boot/grub/grub.cfg
Code:

set timeout=3

  insmod part_gpt
  insmod fat
  insmod efi_gop
  insmod efi_uga
  set root=(hostdisk//dev/sda,gpt1)
  search --no-floppy --fs-uuid --set 45B4-882F
if loadfont /grub/unifont.pf2; then
   set gfxmode=auto
   insmod gfxterm
   insmod vbe
   terminal_output gfxterm
fi

set menu_color_normal=cyan/blue
set menu_color_highlight=blue/cyan

menuentry "Funtoo Linux - vmlinuz-3.16.1" {
  insmod part_gpt
  insmod fat
  set root=(hostdisk//dev/sda,gpt1)
  search --no-floppy --fs-uuid --set 45B4-882F
  linux /vmlinuz-3.16.1 enc_root=/dev/md127 softraid lvm luks luks_trim root=/dev/mapper/duncan--vg-root init=/usr/lib/systemd/systemd pcie_aspm=force acpi_osi=Linux acpi=force acpi_enfore_resources=lax i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 lvds_downclock=1 i915.semaphores=
  initrd /initramfs.cpio.gz
  set gfxpayload=text
}
set default=0
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 529

PostPosted: Sun Aug 31, 2014 1:20 am    Post subject: Reply with quote

This might not apply at all, but if your laptop is a Toshiba (or possibly even if not), then I had a similar problem in which my laptops' fans would not turn on at all until I enabled W.M.I. (Windows Management Instrumentation) support in the kernel. Apparently, they relied on W.M.I. somehow for thermal control/monitoring. They would go up to 90 degrees Celcius but be quite quiet until I changed this, and after that, the fans turned on at appropriate times to keep them cool.

Edit: I guess that yours is an A.S.U.S. Still, what I said might apply. You might also want to check for anything that you might have missed in the vendorspecific kernel settings.
Back to top
View user's profile Send private message
treeman1111
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2013
Posts: 77

PostPosted: Sun Aug 31, 2014 1:34 am    Post subject: Reply with quote

Keet, thank you for the reply! I too have suspected that I am missing some kernel option. Where could I find these vendor-specific kernel settings?
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 529

PostPosted: Sun Aug 31, 2014 1:43 am    Post subject: Reply with quote

Device Drivers > X86 Platform Specific Device Drivers

I would also check Device Drivers > Hardware Monitoring support.
Back to top
View user's profile Send private message
treeman1111
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2013
Posts: 77

PostPosted: Sun Aug 31, 2014 3:33 am    Post subject: Reply with quote

I was able to find the x86 platform drivers that I needed by running lsmod in ubuntu and then enabling those features in my Gentoo kernel. With those features enabled, the laptop runs ~5 degrees cooler. What are the best programs to further lower the temperature?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum