Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help with wpa_supplicant and 2014 gentoo minimal livecd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Gloom_Scythe
n00b
n00b


Joined: 01 Sep 2014
Posts: 12

PostPosted: Mon Sep 01, 2014 2:44 am    Post subject: Help with wpa_supplicant and 2014 gentoo minimal livecd Reply with quote

hello want to install gentoo using a 2014 min. livecd using WPA2. Not going to use another distro's cd sorry so dont mention it. My wireless card is a dlink dwa-552 i believe the module is an ath9k... Tried using google and there isnt much unless its prior to 2008. Please list steps on configuring wpa_supplicant. I do believe this is a major problem that gentoo has at the moment. I have never ran into this issue when installing gentoo. Never installed gentoo via wpa2 before and i have been installing gentoo on various systems since 2002 (I understand wep works fine and/or hardwired). Thank you for your help :). I believe this is possible. If you would like me to list what I have tried via different /etc/conf.d/net options i will... Plus different /etc/wpa_supplicant.conf options. I have gotten very close. I would like people who have gotten wpa_supplicant to work on the latest gentoo livecd (2014 at the moment) to list what they did. Would make a good howto article. I refuse to use another distro to install gentoo. If it is however not possible i request gentoo devs to remove wpa_supplicant from their livecds.... Please and thank you for all of your help.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Mon Sep 01, 2014 3:17 am    Post subject: Reply with quote

Hi,

I do not know exactly what the livcd contain, but I will be simple as possible. All must be done as root user. First, your wireless card should be listed by those commands
Code:
ip link show
ifconfig -a
iwconfig

If not, the ath9k module is not loaded or something went wrong. I will use wlan0 as the wireless logical name, so change it for the good name if needed. Than
Code:
 wpa_passphrase ssid passphrase > /root/wpa_supplicant.conf

where ssid is the Access Point name and passphrase is the password to associate you computer with the AP. Use quotes if the name have space. You are now ready to start wpa_supplicant:
Code:
wpa_supplicant -B -c /root/wpa_supplicant.conf -D nl80211 -dd -f /var/log/wpa.log -i wlan0 -t

If the prompt come back without error, you should be associated with the AP after some seconds. Check with
Code:
iwconfig wlan0

if it is. The name of the AP beside ESSID and it's MAC address beside Access Point should appear for wlan0. The only thing you must complete is to make a Dhcp request to configure your card with an Ip address, a gateway and Dns servers.
Code:
dhclient -v wlan0

or
Code:
dhcpcd wlan0


Test you connectivity with
Code:
host forums.gentoo.org

The command should return the Ip address of the forum.
_________________
Paul
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1969

PostPosted: Tue Sep 02, 2014 3:53 pm    Post subject: Reply with quote

I haven't used the Gentoo livecd (and would anyway use SystemRescue) but the shell script
I use to start wpa supplicant is:
Code:

#!/bin/bash
# Connect using wpa_supplicant running in a terminal.
# Replace -Dwext with -Dnl80211 in modern systems.
date
ifconfig eth0 down
(sleep 10 && dhclient wlan0) &
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf -f/var/log/wpa.log -dd -t
# eof

A typical wpa_supplicant configuration script is:
Code:

# /etc/wpa_supplicant/wpa_supplicant.conf

# The below line must not be changed otherwise we refuse to work
ctrl_interface=/var/run/wpa_supplicant

# Ensure that only root can read the WPA configuration
ctrl_interface_group=0

# Let wpa_supplicant take care of scanning and AP selection
ap_scan=1

# Allow tools to update configuration.
#update_config=1

# Simple case: WPA-PSK, PSK as an ASCII passphrase, allow all valid ciphers
# Use wpa_passphrase to produce the hex string.
network={
  ssid="COINS"
  psk="colorless green ideas sleep furiously"
  #psk=ac2f12127f77a7db8947d31b7864726e039c20965efe0b11270be86a96a09827
  # The higher the priority the sooner we are matched
  priority=5
}


Will
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum