Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WMA/MP3 playback
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
yajforforum
n00b
n00b


Joined: 03 Sep 2014
Posts: 2

PostPosted: Wed Sep 03, 2014 10:39 am    Post subject: WMA/MP3 playback Reply with quote

hey guys..
I try to playback wma and mp3 in my custom board. Alsa uses default sampling rate as 48000. I have files of 44.1K. I have udpated the rate in .asoundrc and /etc/asound.conf files.
But still playbakis 48K. So it is chip munk effect taken place. How to find the location of files, how these config files are overtaken.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Wed Sep 03, 2014 1:14 pm    Post subject: Reply with quote

Let's get a lot more specific. What is your "custom board"? What media player are you using? Post the output of emerge --info.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
yajforforum
n00b
n00b


Joined: 03 Sep 2014
Posts: 2

PostPosted: Thu Sep 04, 2014 9:03 am    Post subject: Reply with quote

custom board is ARM based Marvell kit board(sorry thats all I can open due to confidential matters). I tried playing mplayer, mpg mp3 player and aplay(for wav). Wav also has same effect.
As I mentioned earlier, I did modifications in .asoundrc and /etc/asound.conf. Even changing the rate using plugin, it did not help. Some times wav playback is correct immediately after rebooting the board.
Back to top
View user's profile Send private message
fernan82
n00b
n00b


Joined: 24 Jul 2014
Posts: 70

PostPosted: Sun Sep 07, 2014 1:57 am    Post subject: Reply with quote

Did you triied the --format= and --rate= with aplay? You can try:

Code:

aplay -f cd file.wav


where -f cd is shortcut for 16-bit, little endian, 44100 sps, stereo. If that doesn't work try playing with the --format and --rate options. Once you get it right with a wav file you can try something like this for mp3's with madplay:

Code:

madplay file.mp3 | aplay -f cd


You'll need a way to figure out the mp3 samplerate first. I know you can do this with libmad but I'm not sure it can be done with the executable.
I'm not sure about other programs.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum