Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
blocked packages [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
helio
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 195

PostPosted: Sat Sep 06, 2014 4:51 pm    Post subject: blocked packages [Solved] Reply with quote

Can anyone help to see how I should resolve the following conflicts among the blocked packages? I tried to un-emerge them, which led to even worse problems.

emerge -uND --backtrack=30 world

* IMPORTANT: 11 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!
[ebuild U ] sys-libs/gdbm-1.11 [1.8.3-r4] USE="nls%* -exporter% -static-libs%" ABI_X86="(64%*) (-32) (-x32)"
[ebuild U ] sys-devel/gnuconfig-20140212 [20131128]
[ebuild N ] dev-libs/libaio-0.3.109-r4 USE="multilib -static-libs {-test}"
[ebuild U ] dev-libs/openssl-0.9.8z_p2 [0.9.8z_p1-r2]
[ebuild UD ] dev-lang/perl-5.16.3 [5.18.2-r1]
[ebuild U ] dev-libs/libgcrypt-1.5.4 [1.5.3]
[ebuild U ] dev-libs/openssl-1.0.1i [1.0.1h-r2]
[ebuild U ] dev-lang/python-2.7.7 [2.7.6]
[ebuild U ] dev-libs/gobject-introspection-1.40.0-r1 [1.40.0]
[ebuild U ] dev-lang/python-3.3.5-r1 [3.3.3] USE="sqlite*"
[ebuild N ] sys-fs/quota-3.17-r1 USE="ldap nls tcpd -rpc"
[ebuild N ] sys-apps/systemd-215-r3 USE="acl firmware-loader gudev introspection kmod pam (policykit) python seccomp -audit -cryptsetup -doc -elfutils -gcrypt -http (-kdbus) -lzma -qrcode (-selinux) (-ssl) {-test} -vanilla" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3 (-python3_4)" PYTHON_TARGETS="python2_7 python3_3 -python3_2 (-python3_4)"
[ebuild N ] sys-auth/pambase-20120417-r3 USE="consolekit cracklib sha512 systemd -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)"
[ebuild R ] sys-apps/dbus-1.8.6 USE="systemd*"
[ebuild N ] sys-apps/gentoo-systemd-integration-4
[ebuild N ] virtual/udev-215 USE="-systemd"
[ebuild U ] net-misc/dhcpcd-6.4.3 [6.2.0-r1]
[ebuild R ] dev-libs/redland-1.0.16 USE="(-ssl%*)"
[ebuild U ] dev-libs/apr-util-1.5.3-r2 [1.5.3-r1]
[ebuild NS ] sys-kernel/gentoo-sources-3.14.14 [3.12.13, 3.12.21-r1] USE="-build -deblob -experimental -symlink"
[ebuild U ] virtual/libgudev-215-r1 [208] USE="-systemd%"
[ebuild U ] virtual/libudev-215-r1 [208] USE="-systemd%"
[ebuild U ] sys-cluster/ploop-1.11 [1.9]
[ebuild U ] www-servers/apache-2.2.27-r4 [2.2.27]
[ebuild U ] sys-cluster/vzctl-4.6.1 [4.5.1] USE="vzmigrate%*"
[ebuild U ] sys-apps/man-pages-3.69 [3.67]
[ebuild U ] sci-visualization/gnuplot-4.6.5 [4.6.4-r2]
[ebuild U ] app-crypt/gpgme-1.3.2-r1 [1.3.2]
[ebuild U ] dev-db/mysql-5.5.39 [5.1.70] USE="bindist%* -jemalloc% -static-libs% -systemtap% -tcmalloc%"
[ebuild U ] virtual/mysql-5.5 [5.1] USE="-static-libs%"
[ebuild U ] kde-base/kdelibs-4.12.5-r2 [4.12.5-r1]
[ebuild U ] www-plugins/adobe-flash-11.2.202.400 [11.2.202.394]
[ebuild N ~] kde-base/ksmserver-4.11.11-r1 USE="(-aqua) -debug"
[ebuild U ~] kde-base/plasma-workspace-4.11.11 [4.11.5] USE="kdepim%* -nepomuk%"
[ebuild U ] mail-client/thunderbird-24.7.0 [24.6.0]
[ebuild U ] www-client/firefox-24.7.0 [24.6.0]
[ebuild U ] kde-base/kdebase-startkde-4.11.9 [4.11.5]
[ebuild U ] virtual/perl-Storable-2.410.0-r1 [2.390.0]
[uninstall ] perl-core/Storable-2.390.0
[blocks b ] <perl-core/Storable-2.410.0 ("<perl-core/Storable-2.410.0" is blocking virtual/perl-Storable-2.410.0-r1)
[ebuild U ] dev-perl/DBD-mysql-4.20.0-r1 [4.20.0]
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-215-r1)
[blocks B ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-215-r1)
[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-215-r3, sys-apps/gentoo-systemd-integration-4)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

(dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
=dev-lang/perl-5.18* required by (virtual/perl-Storable-2.410.0-r1::gentoo, ebuild scheduled for merge)
dev-lang/perl:0/5.18=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
(and 6 more with the same problems)

(dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-fs/udev-215-r1::gentoo, installed) pulled in by
sys-fs/udev required by @selected
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-)]) required by (virtual/libudev-215-r1::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-208-r1 required by (virtual/udev-215::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1::gentoo, ebuild scheduled for merge)

(sys-apps/systemd-215-r3::gentoo, ebuild scheduled for merge) pulled in by
>=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r3::gentoo, ebuild scheduled for merge)
sys-apps/systemd:0= required by (sys-apps/dbus-1.8.6::gentoo, ebuild scheduled for merge)


Last edited by helio on Sun Sep 07, 2014 8:38 am; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2585

PostPosted: Sat Sep 06, 2014 4:56 pm    Post subject: Re: blocked packages Reply with quote

The perl blockers often can be solved by running
Code:
emerge --depclean
Also, in order to get rid of old 5.16 you should run
Code:
perl-cleaner --reallyall
Back to top
View user's profile Send private message
helio
Apprentice
Apprentice


Joined: 08 Apr 2006
Posts: 195

PostPosted: Sun Sep 07, 2014 8:36 am    Post subject: Reply with quote

Thanks chalres17 for suggestions.

It seems that emerge won't allow me to install both udev and systemd in the same system. It turns out I had forced a USE flag onto a package in the package.use file, for whatever reason I can't recall now. After I removed that entry in the package.use file, the emerge conflicts are all gone.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum