Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Java Update?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Sat Sep 06, 2014 5:02 pm    Post subject: Java Update? Reply with quote

Guten Abend. Ich habe ein Problem mit Java. Ich habe auf NetBeans 8.0 upgedated, aber beim ausführen kommt folgende Meldung:
Quote:
Java 7 Standart Edition oder höher erforderlich
Die Ausführung auf älteren Java- Versionen als Java 7 standart Edition ist nicht möglich.
Installieren Sie Java 7 Standart Edition oder eine neuere Version, oder weisen Sie mit dem Switch --jdkhome
auf das Installationsverzeichniss hin.

Ein "eselect java-vm list" bringt folgende Ausgabe:
Code:
Aviable Java Virtual Machines:
 [1] gcj-jdk
 [2] icedtea-6
 [3] icedtea-7
 [4] sun-jdk-1.6


Was muss ich Updaten und / oder selectieren?
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sat Sep 06, 2014 6:15 pm    Post subject: Reply with quote

Wie hast du denn Java installiert? Wieso hast du es 4x? Steht es bei dir manuell in der world? Besonders sun-jdk ist doch schon etwas überfällig. Davon sollte man sich so schnell wie möglich trennen.

Ansonsten kannst du mit "eselect java-vm set system x" eine bestimmte setzen.
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Sat Sep 06, 2014 8:08 pm    Post subject: Reply with quote

Danke. Hier mein Lösungsweg:
Code:
emerge -a oracle-jdk-bin
eselect java-vm set system oracle-jdk-bin-1.8
emerge --unmerge sun-jdk


Auch geholfen hat diese Info: http://wiki.gentoo/org/wiki/Java/de
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sun Sep 07, 2014 5:25 am    Post subject: Reply with quote

Du hättest gar kein weiteres Java installieren müssen, es hätte gereicht, mit eseselect eines der vorhandenen auszuwählen, z.B. icedtea-7.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum