Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] USB 3.0 problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
wonski
n00b
n00b


Joined: 10 Apr 2007
Posts: 37

PostPosted: Tue Sep 09, 2014 5:03 am    Post subject: [SOLVED] USB 3.0 problem Reply with quote

Hi, i'm having problems with USB 3.0 ports on my Lenovo G500 laptop.

USB 2.0 works fine.
.
Code:
pabo-g500 pabo # lspci | grep USB
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)



Code:
pabo-g500 pabo # lsusb                                                                                                                                                                                                                                                         
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub                                                                                                                                                                                                     
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub                                                                                                                                                                                                                 
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller                                                                                                                                                                                   
Bus 001 Device 004: ID 0cf3:3004 Atheros Communications, Inc. AR3012 Bluetooth 4.0                                                                                                                                                                                             
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver                                                                                                                                                                                                             
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub                                                                                                                                                                                                     
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub   



Code:
pabo-g500 pabo # dmesg | grep xhci
[    0.983878] xhci_hcd 0000:00:14.0: can't find IRQ for PCI INT A; probably buggy MP table
[    0.984741] xhci_hcd 0000:00:14.0: xHCI Host Controller
[    0.985571] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 3
[    0.986501] xhci_hcd 0000:00:14.0: cache line size of 64 is not supported
[    0.986503] xhci_hcd 0000:00:14.0: No msi-x/msi found and no IRQ in BIOS
[    0.987345] xhci_hcd 0000:00:14.0: startup error -22
[    0.988208] xhci_hcd 0000:00:14.0: USB bus 3 deregistered
[    0.989044] xhci_hcd 0000:00:14.0: init 0000:00:14.0 fail, -22
[    0.989871] xhci_hcd: probe of 0000:00:14.0 failed with error -22


I've checked kernel config with this tutorial:
http://wiki.gentoo.org/wiki/USB/HOWTO

Ports are ok, on Windows 7 works good.

After connecting anything to port USB3 dmesg show nothing.

Tested on kernel 3.14.14 and 3.16.1.

Any ideas?


Last edited by wonski on Tue Sep 09, 2014 7:05 am; edited 1 time in total
Back to top
View user's profile Send private message
vasettoo
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2012
Posts: 77

PostPosted: Tue Sep 09, 2014 6:35 am    Post subject: Reply with quote

Better use
Code:
lspci -k
.
Also post in a pastebin your kernel .config file.
Back to top
View user's profile Send private message
wonski
n00b
n00b


Joined: 10 Apr 2007
Posts: 37

PostPosted: Tue Sep 09, 2014 7:04 am    Post subject: Reply with quote

Thank's for reply.
Code:

pabo-g500 pabo # lspci -k
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
        Subsystem: Lenovo Device 3977
        Kernel driver in use: ivb_uncore
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
        Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
        Subsystem: Lenovo Device 3800
        Kernel driver in use: i915
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
        Subsystem: Lenovo Device 3977
        Kernel driver in use: xhci_hcd
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
        Subsystem: Lenovo Device 3977
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
        Subsystem: Lenovo Device 3977
        Kernel driver in use: ehci-pci
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
        Subsystem: Lenovo Device 3977
        Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
        Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
        Kernel driver in use: pcieport
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
        Subsystem: Lenovo Device 3977
        Kernel driver in use: ehci-pci
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
        Subsystem: Lenovo Device 3977
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
        Subsystem: Lenovo Device 3977
        Kernel driver in use: ahci
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
        Subsystem: Lenovo Device 3977
        Kernel driver in use: i801_smbus
01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun PRO [Radeon HD 8570A/8570M]
        Subsystem: Lenovo Device 3800
02:00.0 Ethernet controller: Qualcomm Atheros QCA8172 Fast Ethernet (rev 10)
        Subsystem: Lenovo Device 3802
        Kernel driver in use: alx
03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
        Subsystem: Lenovo Device 3218
        Kernel driver in use: ath9k



Problem is solved - after enabling in kernel option
Code:
 Message Signaled Interrupts (MSI and MSI-X)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum