Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] cups crashes brother HL4150CDN
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 286

PostPosted: Sat Sep 13, 2014 2:00 pm    Post subject: [solved] cups crashes brother HL4150CDN Reply with quote

Hello dear printer experts.

I have a major Problem with cups. Printing a page (mostly a html-website, it doesn't matter witch browser I use) the Brother HL4150CDN gives a red "!", an "E1" error and demands to be shut off.
I once had this problem, solved by upgrading to cups 1.7.1.
Now it came back affecting all current cups-versions (1.7.1-r1 to 1.7.5).

I am out of ideas and desperate.

PS: I am using gienah's suggetion to use the ppd-file of the W7 driver as there are no wrapper-drivers for gentoo.
_________________
With nice greetings
Vrenn


Last edited by Vrenn on Sat Sep 27, 2014 8:23 am; edited 2 times in total
Back to top
View user's profile Send private message
gienah
Developer
Developer


Joined: 24 Nov 2010
Posts: 211
Location: AU

PostPosted: Sun Sep 14, 2014 5:20 am    Post subject: Reply with quote

A while ago I had a problem where the Brother HL4150CDN would not print a pdf file
which appeared to have a page that output diagrams beyond the width of the page.
Specifying page ranges I could print the rest of the document other than the 1 page
it did not like.

I don't know if that is the problem you are seeing, but like I guess you have to
try something different, so one idea is to try saving the web page to a pdf file
using a web browser extension, something like (I have not used this):

http://www.pcworld.com/article/2023706/print-friendly-for-chrome-optimizes-web-pages-for-printing.html

Then to try printing the pdf file.
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 286

PostPosted: Sun Sep 14, 2014 9:32 am    Post subject: Reply with quote

Good idea! I'm searching for the corresponding firefox-plugin.
But the truce is, that cups >1.6 (excluding 1.7.1) is broken, or cups--filters, or poppler...
I stumbled upon https://code.google.com/p/chromium/issues/detail?id=89122
Brother seems not to use real PS-drivers, but a very fragile emulation-api.

I am stuck in this printer for a while.
right now I am updating libreoffice to unstable.
Libreoffice prints well I think, but by this I get ~amd64 poppler, worth a try ;)

Anyhow, as you suggest the print needs to be chewed for cups. Either a firefox-plugin, or a cups-relay on a NAS if I get one...
But it would be better if cups and brother could talk together eye to eye again :-(
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Sun Sep 14, 2014 9:47 am    Post subject: Reply with quote

Vrenn wrote:
But it would be better if cups and brother could talk together eye to eye again :-(
Does it print the testpage from http://localhost:631/printers/ where you need to select your printer and will find the Mantenance button with "Print Test Page"?
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 286

PostPosted: Sun Sep 14, 2014 11:03 am    Post subject: Reply with quote

It does.
The error is mostly on html-pages, strangely.

Founding some bugs on the web, just for the record:
https://bugs.freedesktop.org/show_bug.cgi?id=18711
https://bugs.freedesktop.org/show_bug.cgi?id=17952
https://bugs.gentoo.org/show_bug.cgi?id=412135

But that are just picks in the dark.
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 286

PostPosted: Sun Sep 14, 2014 11:42 am    Post subject: Reply with quote

I'm not proud of of the way I found a workaround to print my web-pages with firefox (hunted the bug rather like a shaman believing in the ghosts of bitstream with herbs in the right and chicken in the left hand)

But I found a post about poppler and brother printers:
http://ubuntuforums.org/archive/index.php/t-2022997.html

Following commands work:
Code:
lpstat -v
lpadmin -p <printer> -o pdftops-renderer-default=gs
(lpstat -v for the "printername")
The "I believe in the only true standard"-bug should be in the poppler-libs. Switching to ghostscript makes my printer working.
I hope this workaround will last for the next restart and updates. I tested only one (the 100%fail)-print, as only the next few weeks will show if the bug is gone.

Thanks for your advices, they are still options for me!
And thanks to Till Kamppeter and richpri (they describe how to undo these settings too!)
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum